Sign in to follow this  
stratfordman10

Black Screen and Texture Issue

Recommended Posts

For some reason when I fire up P3D the 'Prepar 3D Professional' screen comes up and then my PC screen turns black until it is loaded and then I get weird graphics in my aircraft whereby the flight deck is mainly black and the flight deck dials are not as clear and visible as they should be.

 

I am scratching my head trying to work out what the issue is and would really appreciate any help/assistance.

 

I tried deleting the shaders file but that did not help.

 

Many thanks in anticipation.

 

Michael

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Are you sure you deleted the right shaders file ?

 

Better supply full system details and OS information too, and perhaps include your Prepar3d.cfg as something doesn't sound right. The black screen and aircraft should only happen for a few seconds until the temporary shaders have compiled, and then only on first load. 

Share this post


Link to post

Many thanks for your reply.

 

Could you please confirm that I have deleted the correct shaders file as follows;

 

DiscC\users\owner\app data\local\lockheed martin\P3D V2\shaders.

 

I have a powerful system with a GTX 980 graphics card.

 

CPU : Intel i7 4790 K

 

Hard Disc: Samsung 1TB

 

Memory: Corsair 16GB Vengeance Pro DDR3 160

 

OS Windows 7 64 bit.

 

I am not sure how to attach my CFG file but is there anything in there that I should specifically be looking for?

 

Yes,when I turn on P3D I get the welcome box and then the black screen appears and lasts for a short time and of course I do not get the screen whereby I enter my aircraft,airport ,weather or time of day.

 

Really strange.

 

Would welcome your further comments.

 

Many thanks.

 

Michael

Share this post


Link to post

What happens if you rename your current cfg file and let P3D build a new one? If it works, then start adding back your settings until you zero in on the issue.

 

Are you loading the default flight or a custom flight with custom aircraft? Try starting with a different flight, etc.

 

Vic

Share this post


Link to post

By default the sim launches straight into the flight, and you need to select a menu option to have the create flight screen load as a default.

Looks like the correct shader folder was emptied, so yes, I think we need to see the Prepar3d.cfg to be sure - just cut and past the contents from the same folder where you have the shader folder the file is Prepar3d .cfg

 

What GPU drivers do you have installed for the GTX980 ? Could be you just need a clean uninstall and reinstall of the latest.

 

Download the correct driver for your system (was 353.62, but has just changed to 355.60 today) and then grab DDU from here

http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

Use DDU to fully and cleanly uninstall the old drivers, reboot then install the new. Finally delete the contents of the shader folder once again then reboot the sim.

 

BUT FIRST, please show the .cfg file - it may be you have some strange settings hanging about in there. 

Share this post


Link to post

Hi Vic,

 

Many thanks for your reply.

 

Yes,I let P3D build a new cfg but still the same issue exsists.

 

Normally when I click the PD3 icon it loads up pretty quickly and I am taken straight away to the menu box where I choose my plane,airport,weather and time etc.

 

Now,when I click the icon I get the PD3 Professional box appear and then my PC screen goes totally black with the PD3 screen still visible and loading up the textures etc and then I am taken to the default aircraft on the default runway-not to the Menu choice and I feel that this is the issue but I cannot fathom it out.

 

Any further help would be appreciated.

 

Michael

Share this post


Link to post

Do you have the Show Opening screen enabled? As Louis said, by default it is DISabled and you go to the flight rather than the setup screen. Go into options and enable it.

 

You also might want to consider a repair install of P3D, if all else fails.

 

Vic

Share this post


Link to post

[AContain]

LabelColor=FFFF0000
LabelDelay=1000
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelAirspeed=0
ShowLabelAltitude=1
ShowLabelContainerId=0
ShowLabelDistance=1
ShowLabelFlightPlan=0
ShowLabelHeading=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabels=1
ShowLabelTailNumber=0
ShowUserLabel=0
 
[ATC]
AutoOpenAirTrafficWindow=0
PilotVoice=0
UsePilotVoice=0
 
[ATTACHMENTS]
AutoWeaponSwitching=False
HighlightDuration=1.000000
IgnoreAttachmentForces=True
IgnoreAttachmentWeight=True
UnlimitedCountermeasures=False
UnlimitedWeapons=False
WeaponHighlight=False
 
[CONTROLS]
Controls_Current=Standard
Controls_Default=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
 
[Display]
ActiveWindowTitleBackGroundColor=0,28,140,64
ActiveWindowTitleTextColor=255,255,255
ChangeTime=4.000000
FullScreen=False
FullScreenAutoFill=1
FullScreenExclusive=0
FXAA=0
InfoBrakesEnable=True
InfoCountermeasureEnable=True
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerLeftTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoOverspeedEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoUpperRightBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
InfoWeaponSystemEnable=True
MSAA=2
NonActiveWindowTitleBackGroundColor=24,33,87,64
NonActiveWindowTitleTextColor=255,255,255
SKINNED_ANIMATIONS=1
SSAA=0
TEXTURE_BANDWIDTH_MULT=30
TEXTURE_FILTERING=4
TransitionTime=4.000000
TRIPLE_BUFFER=0
UPPER_FRAMERATE_LIMIT=0
VSYNC=0
WideViewAspect=1
 
[DISPLAY.Device.NVIDIA GeForce GTX 980.0.0]
Mode=2560x1600x32
 
[DISPLAY.Device.NVIDIA GeForce GTX 980.0.1]
Mode=1600x900x32
 
[DynamicHeadMovement]
HeadMoveTimeConstant=1.000000
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
RollAccelOnHeadLat=0.010000
RollAccelOnHeadRoll=0.100000
YawAccelOnHeadLat=-0.100000
 
[FACILITIES]
CITY=
COUNTRY=
GTL_BUTTON=4096
STATE=
 
[GRAPHICS]
AIRCRAFT_REFLECTIONS=1
BLOOM_LEVEL=2
BUILDING_SHADOWS_CAST=0
BUILDING_SHADOWS_RECEIVE=0
CLOUD_SHADOW_CAST_DISTANCE=0
CLOUD_SHADOW_TEXTURE_SIZE=512
CLOUD_SHADOWS_CAST=0
COCKPIT_HIGH_LOD=1
CONTENT_NO_SHADOW=0
DAWN_DUSK_SMOOTHING=1
EFFECTS_DISTANCE=1
EFFECTS_QUALITY=1
EXTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_RECEIVE=0
GROUND_SHADOW_TEXTURE_SIZE=2048
HDR=0
IMAGE_QUALITY=0
INTERIOR_SHADOWS_CAST=1
INTERIOR_SHADOWS_RECEIVE=1
LANDING_LIGHTS=1
LENSFLARE=1
MIPMAP_VC_PANELS=1
NUM_LIGHTS=4
OBJECT_SHADOW_CAST_DISTANCE=2
See_Self=1
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_ULTRA=12
SHADOW_QUALITY=2
SIMOBJECT_SHADOWS_CAST=0
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOW_CAST_DISTANCE=0
TERRAIN_SHADOWS_CAST=0
TERRAIN_SHADOWS_RECEIVE=1
TESSELLATION=1
Text_Scroll=1
TEXTURE_MAX_LOAD=1024
TEXTURE_QUALITY=3
VEGETATION_SHADOWS_CAST=0
VEGETATION_SHADOWS_RECEIVE=0
 
[iNTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
 
[Main]
Fibre_Frame_Time_Fraction=0.01
HideMenuFullscreen=1
HideMenuNormal=0
LabelsSupported=Airplane, Helicopter
Location=760,390,1800,1168,\\.\DISPLAY2
LocationFullScreen=0,0,2560,1600,\\.\DISPLAY2
Maximized=2
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.10=SimObjects\Countermeasures
SimObjectPaths.11=SimObjects\UT2 Aircraft
SimObjectPaths.2="\Aircraft"
SimObjectPaths.3="C:\MyTraffic Proffesional\MyTraffic\Aircraft"
SimObjectPaths.4=SimObjects\GroundVehicles
SimObjectPaths.5=SimObjects\Boats
SimObjectPaths.6=SimObjects\Animals
SimObjectPaths.7=SimObjects\Misc
SimObjectPaths.8=SimObjects\Submersible
SimObjectPaths.9=SimObjects\Weapons
SimObjectPathsRemarks=These entries were automatically added from SimObjects.cfg by Migration Tool. Set RepairConfig=0 in MigrationTool.cfg to disable.
User Objects=Airplane, Helicopter, Submersible, ExternalSim
 
[Misc]
Com_Rate=7
 
[MULTIPLAYER]
condAccoutPassword=0
 
[PANELS]
IMAGE_QUALITY=1
PANEL_MASKING=1
PANEL_OPACITY=100
PANEL_STRETCHING=1
QUICKTIPS=0
SAVE_AND_LOAD_PANEL_STATE=0
UNITS_OF_MEASURE=0
 
[PointOfInterestSystem]
CycleSetting=0
 
[REALISM]
AllowEngineDamage=False
AutoCoord=False
AutoTrim=False
CrashDetection=False
CrashTolerance=1.000000
CrashWithDyn=True
GEffect=True
General=1.000000
GyroDrift=False
GyroEffect=1.000000
ManualLights=True
OnCrashAction=0
PFactor=1.000000
RealMixture=True
StressDamage=True
Torque=1.000000
TrueAirspeed=False
UnlimitedFuel=True
 
[RECORDER]
RecordAirportVehicles=True
RecordAITraffic=True
RecordLeisureBoats=True
 
[sCENERY]
AUTOGEN_BATCH_LOD=2
AUTOGEN_TREE_MAX_DRAW_DISTANCE=9500.000000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
IMAGE_COMPLEXITY=4
POP_FREE_AUTOGEN=1
 
[sIM]
OPTIMIZE_PARTS=1
SYSCLOCK=0
 
[slewTextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
 
[slewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
 
[slewTextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
 
[sOUND]
PrimaryPlaybackDevice={7565DD53-9663-4A16-B220-55D3B0AB70F2}
SOUND=1
SOUND_FADER1=0.500000
SOUND_FADER2=0.500000
SOUND_FADER3=0.500000
SOUND_FADER4=0.500000
SOUND_LOD=0
SOUND_QUALITY=2
VoiceCaptureDevice={450C71B9-33C5-4557-9D6D-67990F86D891}
VoicePlaybackDevice={4CDA35E5-F2DF-40E9-AE73-93E03C9F9776}
 
[sTARTUP]
DEMO=0
LOAD_SIMDIRECTOR=1
LoadWindow=1
STARTUP_DEMO=
 
[TERRAIN]
AUTOGEN_BUILDING_DENSITY=1
AUTOGEN_VEGETATION_DENSITY=1
DETAIL_TEXTURE=1
ENABLE_BATHYMETRY=0
LOD_RADIUS=4.500000
MESH_RESOLUTION=23
TESSELLATION_FACTOR=75
TEXTURE_RESOLUTION=28
UseGlobalTerrainView=False
WATER_CLARITY=30
WATER_DETAIL=1
WATER_REFLECT_AUTOGEN_BUILDINGS=0
WATER_REFLECT_AUTOGEN_VEGETATION=0
WATER_REFLECT_CLOUDS=1
WATER_REFLECT_SIMOBJECTS=0
WATER_REFLECT_TERRAIN=0
WATER_REFLECT_USERAIRCRAFT=1
WATER_REFRACT_AUTOGEN_BUILDINGS=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_USERAIRCRAFT=0
 
[TextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
WindDirectionAndSpeed=1,6
 
[TextInfo.2]
FrameRate=1,1
FuelPercentage=1,4
GForce=1,3
LockedFrameRate=1,2
 
[TextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
FuelPercentage=2,4
GForce=2,3
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
WindDirectionAndSpeed=1,6
 
[TrafficManager]
AirlineDensity=0
AIRPORT_SCENERY_DENSITY=0
FreewayDensity=15
GADensity=0
IFROnly=0
LeisureBoatsDensity=5
ShipsAndFerriesDensity=5
 
[uSERINTERFACE]
Map_Orientation=2
MUTE_ON_LOST_FOCUS=1
PAUSE_ON_LOST_FOCUS=0
PROMPT_ON_EXIT=1
RestoreTimeOnMove=0
SHOW_MISSION_CAPTIONS=0
SHOW_SCENARIO_WINDOW=1
SITUATION=C:\Users\Owner\AppData\Local\Lockheed Martin\Prepar3D v2\Prepar3D_Default
 
[VirtualCopilot]
VirtualCopilotActive=0
 
[Weather]
AdjustForMagVarInDialog=1
CLOUD_COVERAGE_DENSITY=6
CLOUD_DRAW_DISTANCE=6
DETAILED_CLOUDS=1
DisableTurbulence=0
DownloadWindsAloft=0
DynamicWeather=0
MaxGustRampSpeed=200
MaxGustTime=500
MaxVarRampSpeed=75
MaxVarTime=50
MinGustRampSpeed=1
MinGustTime=10
MinVarRampSpeed=10
MinVarTime=5
OPTIMIZE_DENSE_CLOUDS=0
THERMAL_VISUALS=0
TurbulenceScale=1.000000
VolumetricFog=1
WeatherGraphDataInDialog=0
WindshieldPrecipitationEffects=1
 

Opening screen issue now resolved.

 

CFG for your perusal.

 

Look forward to hearing from you.

 

Michael

Share this post


Link to post

So you are still getting the black screens? Your cfg file looks good - nothing that would cause you the problems you described.

 

You could change a few settings but they really would have no effect on your initially described problem.

 

Vic

Share this post


Link to post

I have resolved the issue of the black screen through the adjustment in the options menu.

 

The black textures have also now resolved themselves but I am not sure how.

 

My only current issue is that my exe crashes after about 30 mins but I guess I am not on my own with this problem.

 

Anyway,many thanks for your help and time.

 

Michael

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this