Sign in to follow this  
kiosutra

Windows 10 issue

Recommended Posts

Hey gang! My computer somehow auto updated to windows 10. Not a huge issue concerning FSX. But I have a problem exiting the program. If I wish to end the flight, I would normally press escape and end the flight. But when I do so...the screen goes blank and nothing happens. I have to use task manager to shut FSX down. 

 

Now, here is a clue for you smart peeps to help me. I enjoy using FSX in fullscreen mode. That is were the issue springs up. Although, if I run the program in windowed mode (WHICH FLIPPING HATE DOING) it will allow me to exit as usual. 

 

Any help would be greatly appreciated 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

To properly help you, we need far more information: what system do you use, graphics card you use, which driver, which settings, DX10 or DX9? It seems that there are some issues with FSX on W10 using the DX9 mode...

Share this post


Link to post
Share on other sites

I stand to be corrected, but I think this is just a graphical bug with FSX and W10.

 

The issue is that dialogue boxes do not display properly when in full screen mode (try accessing any menu function and you'll get the same black screen). The dialogues are there, you just can't see them, so if you just hit Enter when the screen goes black the exit sequence continues as normal (hitting Enter simply presses the OK button that you can't see).

 

The only real workaround I've found is to switch to windowed mode prior to any FSX menu access (obviously you can just switch back to full screen once you're done).

 

I do run in DX9 mode though (with an Nvidia GTX560) -- be interesting to hear whether running in DX10 mode has any effect on this.

Share this post


Link to post
Share on other sites

Well, all I can say is that I run my FSX in DX10 mode on W10 (using Steves Fixer) and I do not have any issue, not regarding dialogue boxes, not regarding menue, nothing. And I use fullscreen mode. And DSR. And nVidia Inspector forcing high antialiasing settings. Works perfect on my W10 build. But it took me some time: first, I had troubles with the new nVidia driver, then I realized that SweetFX does not work at all under W10 and in the end, I needed to reconfigure my nVidia Inspector settings again as the profile from W7 did not work under W10. But now, everything is back to normal and it seems that I even have a more fluent sim I ever had in W7...

Share this post


Link to post
Share on other sites

Have you updated your Nvidia drivers via the nvidia website? (not the Windows provided ones).

Share this post


Link to post
Share on other sites

This is an automatic message.

 

This topic has been moved from "MS FSX | FSX-SE Forum" to "WIN10 OS Forum". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

I am running DX9 and use  2 Invidia 570GTX cards. Also use Invidia inspector for configuring. I downloaded the latest driver but still have the same issue. 

Share this post


Link to post
Share on other sites

Did you delete the shader cache files and let FSX build new ones?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this