Sign in to follow this  
turboken

Prepar3D V3 V-Sync Broken?

Recommended Posts

First I want to say great job LM on Pv3 It looks amazing compared to FSX.

 

Unfortunately I am getting bad screen tearing. I have tried every combination of v-sync/FPS slider in prepar3d and nvidia profile I can think of and cannot get rid of it.

 

Just to be clear I have a fast system that runs FSX great. devils canyon @ 4.8 with Prepar3d on dedicated m.2 drive and a GTX970.

 

As far as frame rates go I have turned almost all scenery OFF just to make sure I'm not overloading the scenery engine. I can get 70-90 FPS and still get screen tearing. Then click on v-sync and the FPS drops but the image tearing will continue. 

 

Cool thing about Prepar3D is I can crank the scenery really high almost everything MAXED and get decent FPS still, but then when you are zoomed out looking at the airplane and panning the image starts to tear. Turning scenery down slightly improved this but no where near as fluid as FSX is. I have tried 3 different drivers including deleting the shader folder and nothing helps.

 

Any ideas as I cannot imagine this being normal, I will try and reinstall soon and report back. Any ideas would be appreciated as it is really not playable as it is.

 

 

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Turboken,

 

I had the same problem and it was driving me crazy!..lol  I found my solution after some times of having the screen tearing issue with P3D2.5 and v3.  

 

Now, this is if your running windows 7.  You have to turn on Aero Desktop and it will get rid of the screen tearing.  I turn it on and the screen tearing is completely gone!..I couldn't believe it.  I've had that off for years!...I remeber another game I use to have screen tearing, now I know why!! I never would have figured it out if it wasn't for someone that mention it on YouTube during my research into this

 

So, make sure you select as a desktop background to Aero in Windows 7

 

Hope it helps!

Share this post


Link to post

Hi Turboken,

 

I had the same problem and it was driving me crazy!..lol  I found my solution after some times of having the screen tearing issue with P3D2.5 and v3.  

 

Now, this is if your running windows 7.  You have to turn on Aero Desktop and it will get rid of the screen tearing.  I turn it on and the screen tearing is completely gone!..I couldn't believe it.  I've had that off for years!...I remeber another game I use to have screen tearing, now I know why!! I never would have figured it out if it wasn't for someone that mention it on YouTube during my research into this

 

So, make sure you select as a desktop background to Aero in Windows 7

 

Hope it helps!

 

That was it! Thank You for the reply.

 

I actually read this somewhere and tried it as soon as I got home. Works great.

 

Wow, V3 is amazing.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this