Jump to content

Sign in to follow this  
rswacker

G1000 stuttering on Win 8.1

Recommended Posts

I recently bought the Mindstar G1000 and I'm very impressed with it, but I'm having a problem with stuttering that's making it unusable.  I see a similar thread from about a year ago, but I don't see how it was resolved.  I've got a modest system, but it's able to run most high-end aircraft (PMDG, Eaglesoft, Flight1) well.  Here are my specs:

 

Dell laptop

Intel Core i5-5200U, 2.2GHz

Intel HD Graphics 5500

8 GB RAM

Win 8.1 64 bit

 

I run FSX SP2 w/ FSUIPC, TrackIR, Active Sky Evolution, full-screen on a second monitor.  Display settings are all mid-range with frame rate locked to 31 fps.  Autogen and ground traffic are off.

 

Here are frame rates I see for various airplanes in the pattern during day MVFR conditions at I19 with a GPS approach loaded:

 

Default C172 w/ RXP GNS 530:  28-30 fps

Default C172 w/ FSX G1000 and RXP GNS 530:  24-30 fps

Carenado SR22 w/ RXP GNS 530:  16-24 fps

Flight1 T182T:  18-24 fps

Flight1 Mustang:  12-18 fps

Default C172 w/ Mindstar G1000:  12-18 fps, but with drops to 1-2 fps during stutters every several seconds

 

My invoice number is 2005086 and my purchase date was 4 Oct.  Thanks for any help you can provide to get this working better.

 

Bob Wacker

Share this post


Link to post

That video system isn't doing you any favors, to be honest. However, I recommend you contact our support via email and see if they can find something that's not quite right with your installation/system.


Ed Wilson

Mindstar Aviation
My Playland - I69

Share this post


Link to post

Will do.  Understand about the graphics card, but since other resource-intensive add-ons are running successfully, I'm hopeful that the G1000 can work as well.  Thanks for the reply.

 

Bob

Share this post


Link to post

I'd like to re-engage on this here in the forum, since I haven't received any reply via email on this since Oct 22.  Here's the last message I got from Mindstar:

 

"We don't see that kind of drop of frame rates on our system, but the fact that you're seeing it happen ever few seconds is a clue. Every few seconds, we hit the Microsoft (or Prepar3D) database for information about surrounding airports, navaids, etc, and we also update the MFD map (or the PFD inet map if it's showing, etc). These tasks are disk-cache intensive and processing intensive, so I wonder if the issue is related to your system having some difficulty querying the Microsoft built-in data, and rendering the GPS map. One thing we do in our systems is we don't use traditional hard drives, we use SSD drives.  We also stick with i7 processors just to get maximum performance. Your RAM amount is irrelevant on your particular system because even though you have a 64-bit system, FSX and Prepar3D are only 32-bit applications, so they can only "see" approximately 4GB of RAM, regardless of how much you load onto the machine. Out of curiosity, if you load the G1000.INI into Notepad (the file is loaded in C: \ Program Files (x86) \ Mindstar \ Flight Simulator Addons), and change the GPS_REDRAW_RATE to a value of 10.

 

That value will tell the GPS refresh itself every 10 seconds. While this may not be a good final solution, it would tell us whether my theory about data collection and image rendering is in fact part of the problem."

 

And here's my reply:

 

"Thanks for the information.  I just tried several different redraw rates.  The stuttering sort of correlates with the redraw rate, but it's definitely more frequent than the MFD redraws.  When I set it to 10 seconds, the stutters happened every 4-12 seconds.  When I set it to 2 seconds, the stuttering was nearly continuous.  When I set it to 20 seconds, the stutters went back to once every 4-12 seconds.  When I go to a very remote area, like Johnston Atoll in the Pacific, I experience virtually no stuttering at all.

 

Some additional information:  I've subscribed to Realnavdata, so I'm using that database, rather than the native FSX database, but the problem appears to be about the same regardless of which nav data source I'm using.  Also, as part of my troubleshooting, I reinstalled the G1000 in C:\Mindstar, which didn't improve anything.  I run Norton Antivirus, but I've excluded every folder I can think of from real-time scans (C:\Mindstar, C:\Program Files (x86)\RealNav, C:\ProgramData\RealNav), so I don't think NAV is the culprit.

 

Thanks again for your help."

 

A follow-up query on Nov 14 didn't produce a reply.  I'd really appreciate some further suggestions of things I can try to isolate and fix this problem.

 

Thanks,

Bob Wacker

Share this post


Link to post

Doesn't Win8 have this Windows Defender and some other thing called Windows Error Reporting (might not be exactly right)? I have seen where those two applications can cause issues with other addons.


Ed Wilson

Mindstar Aviation
My Playland - I69

Share this post


Link to post

I have reviewed your support ticket and based on it as well as your system specifications, I'm beginning to think this is hardware related. Is this a laptop you're running this on?


Ed Wilson

Mindstar Aviation
My Playland - I69

Share this post


Link to post

Yes, it's a Dell Inspiron 5749, Intel i5 2.2 GHz, Intel HD Graphics 5500.  If it's a hardware problem, though, I'd think it would manifest itself with other add-ons.  I can run the following with no problems:

- PMDG B737

- Eaglesoft Citation X

- Flight1 Mustang and C182

- Carenado SR22

- Milviz BE55

- Baytower RV7

- RXP GNS 430 and 530

- Flight1 GTN 650 and 750

- ActiveSky Evolution

Share this post


Link to post

What you can run really isn't relevant, and I really don't know where that process started... maybe back in the DOS days or something.

 

There is something going on with your system that is causing a problem with our G1000... of course the million dollar question is what...


Ed Wilson

Mindstar Aviation
My Playland - I69

Share this post


Link to post

Well, if it doesn't affect other Flight Simulator add-ons, then what other symptoms of this hardware problem should I look for elsewhere on my computer?

Share this post


Link to post

Here's the thing... there's no long list of individuals having this problem. There's nothing about the G1000 itself that has anything to do with any of the addons you are trying to use as a comparison.

 

In short... there's nothing pointing any direction except that it's something to do with your specific system. It could be an overly aggressive anti-virus software interrupting absolutely every single file access (data reading). It's not the G1000 software itself... it's something on your system that's not playing nice with it... and it's really not going to be easy to figure it out.


Ed Wilson

Mindstar Aviation
My Playland - I69

Share this post


Link to post

If my antivirus software is overaggressive and interrupting file access then why is it not doing that to every add-on that I use, and for that matter, everything else I run on my computer?  Why is it choosing to single out the Mindstar G1000?  As I mentioned earlier, I exclude every FSX and add-on related folder I can identify from Norton's autoprotect feature, to include C:\Mindstar and C:\Program Files (x86)\RealNav.  Are there other folders that aren't readily apparent that I should also exclude?

 

I'm not the first to have this problem with the Mindstar G1000.  See the thread started by "zazaboeing" in this forum from 18 Nov 2014.  I'm sorry that this isn't going to be easy to figure out, but I paid for a product that you claimed would work with the system I have.  There are probably others out there with this problem and it's in everyone's interest to figure out why it isn't working right.  I'm standing by to provide whatever information you need to try to isolate and fix the problem.

Share this post


Link to post

Mr. Wacker,

 

No one said you were the only person with the issue, in fact I simply stated there wasn't a long line.

Also my point about this not being easy was to let you know it will take some time and require patience... not to imply anything else that you dredged up.

 

On this note... it's time for you to return to the support email process as there's nothing further I can do regarding this issue. I will ensure you are contacted this week by a support representative.


Ed Wilson

Mindstar Aviation
My Playland - I69

Share this post


Link to post

Sorry, the person you need to talk to has been out sick.


Ed Wilson

Mindstar Aviation
My Playland - I69

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...