Sign in to follow this  
Flint10

Problems connecting FS2CrewNGX Reboot with PMDG737NGX in P3DV3

Recommended Posts

I am having problems connecting FS2Crew PMDG NGX Reboot with the latest (i.e. as of 11/12/15) PMDG 737NGX in Lockheed Martin P3D version 3.

 

I have followed all the advice in the FS2Crew PMDG NGX Button Control Tutorial (although the tutorial doesn't show the current FS2Crew PMDG NGX Reboot Config Manager).

 

I have followed the advice regarding running both FS2Crew and P3D as 'Administrator', and ensured that UAC is disabled. I have ensured that the default aircraft is loaded first in P3D. Loaded the PMDG 737NGX in 2D View. Allocated FS2Crew's Main and Secondary buttons in P3D Controls.

 

After ensuring all the above I have noted that when I load PMDG 737NGX I am not asked "if I Trust the new FS2Crew gauge". 

 

When I start PMDG 737NGX in P3D and select either Main or Secondary buttons FS2Crew is not available. It is obvious that FS2Crew is not communicating with PMDG 737NGX/P3D. 

 

After cleaning registry with CCleaner I have done a clean re-install of both FS2Crew PMDG NGX Reboot and PMDG 737NGX but still FS2Crew doesn't communicate with P3D.

 

This is also the case with my anti-virus software disabled and windows firewall turned off.

 

I am now completely bewildered.

 

Any help/advice would be most welcome as I have spent many hours on this and am beginning to think that FS2Crew is a complete waste of money.

 

My system:

Windows 8.1 - 64-bit

CPU Intel i7-4790K 4.0GHz

RAM 8 GB

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Your problem is that there are no FS2Crew entries on the NGX's panel.cfg.

 

Did you run the FS2Crew NGX Reboot Config Manager and "Enable" FS2Crew?

 

That adds FS2Crew to the NGX's panel.cfg file

 

 

Make sure you run everything with Admin rights to Avoid write permission issues.

 

If FS2Crew is not added to the panel.cfg file, it's usually due to a write permission issue.

 

Right click on the FSX.EXE and select "run as adminstrator" in the Compatibility section.

Share this post


Link to post
Share on other sites

Hi Bryan,

 

I do have FS2Crew entries in the NGX panel.cfg file thus:-

 

------------------------------------------------

//FS2Crew windows
 
[Window20]
size_mm=1069, 51
window_size= 0.5567, 0.0425
window_pos=0.00,0.05
visible=0
ident=1000
zorder=100
sizeable=1
gauge00=FS2CrewNGXRB!FS2Crew_MainPanel, 0,0,1069,51
gauge01=FS2CrewNGXRB!FS2Crew_Audio, 20,20,5,5
gauge02=FS2CrewNGXRB!FS2Crew_VoiceMain, 10,10,5,5
 
 
[Window21]
size_mm=402, 639
window_size= 0.2093, 0.5325
position=3
visible=0
ident=1001
zorder=105
sizeable=1
gauge00=FS2CrewNGXRB!FS2Crew_SecondaryPanel, 0,0,402,639
 
//FS2Crew windows end
 
----------------------------------------------------------------------------
 
I have set both FS2Crew and P3D to run with Admin rights in the Compatibilty settings.
 
I have not been asked " .....to Trust the FS2Crew gauges when the NGX is loaded" yet. Even though The panel.cfg files show new FS2Crew entries as above.
 
There is another issue, That is P3D cannot load NGX in the 2D view as default. Is this an issue. If so how do I load NGX as 2D view as default?
 
Thanks,
 
Alan Goodley. 

Share this post


Link to post
Share on other sites

Hi Alan,

 

It's not an issue in P3D it seems starting in the VC instead of the 2D.  P3D V3 is generally much more reliable than FSX.

 

I don't think P3D asks if you want to "trust" the gauges... that's an FSX thing only.

 

 

Try opening the Main Panel via the VIEWS - INSTRUMENT PANEL menu.

 

If that works, then your assignment for Autofeather Arm/Off needs to change.  I use the "N" key.

 

 

Let me know.

 

Last possible reason is your anti-virus quarantined a required file.

 

 

 

Best,

Share this post


Link to post
Share on other sites

Hi Bryan,

 

thanks for the info.

 

At last I have managed to get the FS2Crew Gauge running thanks to your last post.

 

For some reason my joystick button assignment doesn't work. I have now assigned keyboard button 'N' and it seems to be OK.

 

Thanks for your speedy response on this issue.

 

Alan 

Share this post


Link to post
Share on other sites

Hi Byork,

 

have the same problem. When I open over the views, instrument panel FS2Crew open but I have only a black Window.

Reinstall doesn´t solve the problem.

 

greets

Ben


solved the problem. Repair the PMDG 737 and enable FS2Crew and It works

Share this post


Link to post
Share on other sites

 

solved the problem. Repair the PMDG 737 and enable FS2Crew and It works

 

Glad you got it sorted!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this