Sign in to follow this  
kriggelb

getting message "Effects Have Changed" from time to time without changing scenery or aircraft or anything else

Recommended Posts

Hello everybody,

I noticed a strange issue lately: Without changing anything in FSX or other addons I get the message mentioned above - I'm referring to the message we certainly all know after changing scenery or aircrafts.

For instance it happens when opening the FlyTampa Configurator (without changing anything - just to check the season settings, for example) and then using FlusiFix (a small tool to open fsx.cfg, for example) - also: without changing the fsx.cfg file (just checking settings).

Is this something I should worry about? I find it rather strange - as if something was changing the effects directory without having changed something intentionally myself...

I hope somebody can give me a hint!

Kind regards,

Chris

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just a small update:

The message seems to appear every time I open fsx.cfg via the Flusifix-tool. I don't need to change anything - it seems to be triggered by simply opening and scrollig in the Fluisfix-tool. As if the scenery fixer-interface interprets the reading of a file as actually changing the effects directory!

Quite strange, isn't it?

Share this post


Link to post
Share on other sites

The fixer calculates a checksum on the dates of all the files in the effects directory and writes it into the fixer dx10.ini. When it runs it recalculates and compares. If they are different then you get the popup. It isn't interested in fsx.cfg so the Flusifix tool must be doing something else.

Share this post


Link to post
Share on other sites

Hello Steve,

thanks a lot for the answer!

I guess I found the file which is triggering the message: Within the Flusifix folder there is a file called "FlusiFix06_de.ffl" and it seems to be an index file. The type name is called "indexcreation-index". Interestingly it is updated each time I open Flusifix - even without changing anything.

Maybe that's the reason for the message.

As I see it that's not a real problem, is it?

Kind regards,

Chris

Share this post


Link to post
Share on other sites

I don't think its a problem just an annoyance.   If you have just run FlusiFix then you can use the ignore button on the effects dialog or rescan as you wish.

 

It cannot be the index file in the flusifix  folder as the fixer only looks at the files in the FSX Effects directory.  I can only imagine that in some way it updates the timestamp of the effects directory or one of the files - perhaps it keeps an index file in each directory?  is there is one in the effects directory called Flusi* ?

Share this post


Link to post
Share on other sites

Ok, then here is another possibility - thanks for your hint, Steve:

There is a file called effect.CFG within the Effects folder which clearly gets updated when starting the Flusifix tool. I checked it: There are no changes made - it is just an updated time behind the files name. So obviously nothing to worry about :wink: .

 

This is the file's text:

 

; These particle spite limits are applied based
; on the "Special Effect Detail" settings slider.

[sprite Limit]
Medium=5000
High=9999999999
Low=1000

; These particle emit rate modifiers are applied based
; on the "Special Effect Detail" settings slider.

[Emit Rate]
Medium=0.700000
High=1.000000
Low=0.300000

; If an emitter has its LOD flag set and the viewpoint is
; further away than this at the time the effect is started
; then the emitter will be disabled.

[Detail]
Forced Distance=250

; The [Emitter Detail Distance] and [Emitter Detail Modifier]
; tables work together. If an emitter is further away than a
; distance specified in the distance table then the rate it
; emits particles at is scaled by the factor specified in the
; modifier table.

[Emitter Detail Distance]
Medium=5000
Far=10000
Very Far=15000

[Emitter Detail Modifer]
Medium=0.700000
Far=0.500000
Very Far=0.000000

Test=1

Share this post


Link to post
Share on other sites

Thanks a lot, Steve!

As I know now that it's not a problem it doesn't bother me that much - still thanks for your effort!

Kind regards,

Chris

Share this post


Link to post
Share on other sites

Hello Steve!

Thank you so very much for your support: Your exclusion of the file mentioned above works great with v3.0!

Greeting,

Chris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this