Sign in to follow this  
wulfbindewald

Strange flickering when using FSX in DX10 full screen mode

Recommended Posts

Hi there,

 

recently I loaded the new Orbx FTX Southern California scenery.

 

In few places e.g. in Santa Barbara area and airport I recognized strange and strong flickering over the whole monitor screen in "full screen mode" at dawn and (less) during night, not at the day. Unfortunately it is impossible to make a self explaing pic of this flickering.

Even in much more dense area e.g. Los Angeles  no prob.

 

DX9 overall and DX10 window mode(!) work fine.

Before I ask Orbx I would appreciate your help and advise as it seems superficially to be a DX10 issue.

 

What I have checked so far:

Ground scenery shadows are unswitched.

Reduced autogen density.

Gone back to an earlier Nvidia driver.  

View from VC or only from outside.

Different aircraft (B737 FSX default)

No recognizible GPU (GTX980 OC) overload.

Real weather and clean weather.

Legacy slider to the left.

 

Which further switch in the DX10 controller menu is worth to be checked/unchecked?

 

EDIT: After further investigation I could significantly reduce the flickering risk reducing the car traffic density from 10 to 5%.

But this soln is not my favourite one.

 

Wulf

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Does the flickering effect the sky equally as well as the ground?

Share this post


Link to post
Share on other sites

Does the flickering effect the sky equally as well as the ground?

yes, depending on the location the whole sky turns to black in short time steps

Share this post


Link to post
Share on other sites

The shaders don't know whether they are full screen or not, they just draw triangles. Therefore based on your description I can only conclude its a GPU, power or driver issue.

 

Have you tried turning sgssaa off? Also try using a pure AA level so 4x rather than 4x Csaa

Share this post


Link to post
Share on other sites

The shaders don't know whether they are full screen or not, they just draw triangles. Therefore based on your description I can only conclude its a GPU, power or driver issue.

 

Have you tried turning sgssaa off? Also try using a pure AA level so 4x rather than 4x Csaa

sgssaa off (Nvidiainpector set to Nvidia default) and AA 4X would solve this appearance issue. Thanks for Your help!

 

But due to unacceptable shimmering on I will continue to use as a compromise 8XCSAA again plus proven Nvidiainspector settings, but to reduce the ground vehicle settings from 10 to 5%. One thing I´ll check is to reduce from 4 to 2 SGSS.....as a further compromise.

 

Topic closed so far.

Share this post


Link to post
Share on other sites

Well before you do that, the fact that sgssaa fixes it hints again at a GPU issue ( caused by the scenery). Sgssaa is purely in the gpu, CPU isn't involved. Perhaps the scenery has a lot of overdraw?? Could there be an issue with your GPU OC?

Share this post


Link to post
Share on other sites

Perhaps the scenery has a lot of overdraw??

There are 2 with steadily moving ground vehicles and high frequented highways in Santa Barbara next to the airport.

 

Could there be an issue with your GPU OC?

The card is a factory overclocked gaming GPU from Gigabyte. Maybe a down clocking would be here a solution, but I´ve no experinece with this.

Share this post


Link to post
Share on other sites

Does the menu bar and right click menu work when this is happening?

Share this post


Link to post
Share on other sites

Does the menu bar and right click menu work when this is happening?

The menu bar on the top of the screen does not work, as due to the "wild" flickering the whole screen is impacted.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this