WhiskeySierra

Navigraph Expansion Issues ~ P3D v3

Recommended Posts

Hi again! I purchased the Navigraph Expansion off JustFlight as it said it was compatible with P3Dv3, however when I go to the installer it doesn't have an option to install for P3Dv3. Is there any way to force it to work please? I tried browsing the file location to be set in Program Files (X86).. etc etc.. P3DV3, however this didn't seem to work. Thanks :)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi again! I purchased the Navigraph Expansion off JustFlight as it said it was compatible with P3Dv3, however when I go to the installer it doesn't have an option to install for P3Dv3. Is there any way to force it to work please? I tried browsing the file location to be set in Program Files (X86).. etc etc.. P3DV3, however this didn't seem to work. Thanks :)

Until they come up with an installer you will have to select "Browse" and then navigate to the P3Dv3.1 folder then click okay and it will begin the installation program.  When finished, the aircraft won't be installed in P3D.  You will find the installation files over at C:\Program Files (x86)\Carenado Installer.  Now all you have to do is move the installation to the appropriate folders.  For instance, you'll see a Carenado Navigraph folder.  Move or copy it to the main directory of P3Dv3.1.  In the Carenado Installer folder, open up Carenado folder and you will see a couple of files that should be copied or moved to the main directory of P3DV3.1.  Once that's all done, then you need to open up your dll.xml file (located in the same folder as your P3D.cfg) and enter the following:

 

<Launch.Addon>

    <Name>Carenavigraph</Name>

    <Disabled>False</Disabled>

    <Path>.\Carenavigraph.dll</Path>

  </Launch.Addon>

 

That's it.  Start up the sim and load the Phenom 300 and you should have the 2013 version of the Nav data installed.  If you want to update the NavData by using Navigraph FMS Data Manager you can but make sure you tell the Navigraph program where P3Dv3.1 is located otherwise it will create a P3Dv3 folder and install the navdata there.  That's okay but you will then have to move it over into the P3Dv3.1 folder.  Fun stuff!

 

There is no installer for P3Dv3.1 yet and no one, including JustFlight, has the installer yet.

 

Best regards,

Share this post


Link to post
Share on other sites

Looks like Carenado updated the installer for V3.  I bought a few weeks ago and it was not updated yet.  Sent a note to them and a week later, it's been updated.  Installs fine.  Just select P3D for version (there is no offered version) and it will find your main P3D folder.  Installs and works fine now.

Share this post


Link to post
Share on other sites

It is still the 1.3 Installer for the Navigraph extension and the Phenom 300 and they do not install directly into P3D for me.

 

Best regards,

Share this post


Link to post
Share on other sites

the v1.3 installed directly into my P3D V3 (C:\program files x68\lockheim p3d v3/ carenadonavigraph\...) set the .dll file as above but still NO able to choose any sid or star. or fill in a flight plan .

have a blinking cursur and that's it. :mad:

if i install it without the exp pack than it works oke. no problem here .

but the data base in not there installed where the exp pack gose.

 

so where is the standard database installed withouit the exp pack ?

 

maybe if the exp pack is installed there manualy .. maybe it workd this way ?

 

:hi:

Share this post


Link to post
Share on other sites

 

 


the v1.3 installed directly into my P3D V3 (C:\program files x68\lockheim p3d v3/ carenadonavigraph\...) set the .dll file as above but still NO able to choose any sid or star. or fill in a flight plan .

 

So it must not be installed properly OR you are not following the instructions in the Navigraph G1000 manual and the G1000 Phenom300 manual.  I used the Navigraph G1000 to learn to program the G1000.

 

If it is installed properly, you will see a SID when you select PROC then Departure (after entering an arrival and departure location in the FPL).  If you do not then it simply is not installed properly.  To change the SID and departure runway, you MUST use the GCU 477 Unit below the G1000.  It will not work using the inner and outer keys on the G1000. 

 

The GCU 477 is easier to use anyway.  You hit FPL and the FPL opens with a blinking cursor telling you to select a destination first.  You hit the inner or smaller knob twice and it opens a new window with a blinking cursor first and and a non-blinking cursor ready for input. On the GCU 477 you use the keyboard to enter your destination and then hit ENT.  Use your Outer Knob to move down to the blank line for departure.  Hit the inner or small knob twice and then use the keyboard on the GCU 477 and enter the departure location and then hit ENT.  You now have your to/from done.

 

Hit the PROC button.  Use outer/larger knob to move down to the Departure (I use the middle button on my Mouse to do this) and then hit ENT.  Use your outer knob to move down to the Departure SID.  Use the inner or small knob to scroll through the various SID's.  Once one is selected, hit ENT and your cursor will move to the takeoff runway.  Use the inner knob to scroll through the various runways and select ENT.  Your cursor will move to the Transition which you can scroll through using the inner knob.  Once selected, hit ENT and you will be taken to LOAD?.  Hit ENT.  Your departure is now complete.  Do the same for the Arrival.  All very simple and it works perfectly (using the GCU 477).

 

Again, if you do not see SID's when you move to Departure in the FPL, then your Navigraph Extension is not installed properly.

 

Apologize for the delay in responding.  Hope this helps.

Share this post


Link to post
Share on other sites

IF YOU USE Prepar3d 3.2x, the VOR, FIXES, ICAO AIRPORT will not be showed on map. I just contacted the carenado via ticket. I am very disappointed.

Share this post


Link to post
Share on other sites

IF YOU USE Prepar3d 3.2x, the VOR, FIXES, ICAO AIRPORT will not be showed on map. I just contacted the carenado via ticket. I am very disappointed.

I just finished doing a flight from KLAX to KSFO and they were all there for me!!  But I have a later version of P3D - v3.3.5. 

 

I doubt you can get a refund but I do know they will be updating this aircraft to be compatible with P3Dv3.  Hopefully that will not be too long for you to wait.

Share this post


Link to post
Share on other sites

I just finished doing a flight from KLAX to KSFO and they were all there for me!!  But I have a later version of P3D - v3.3.5. 

 

I doubt you can get a refund but I do know they will be updating this aircraft to be compatible with P3Dv3.  Hopefully that will not be too long for you to wait.

Jimmy, i have that issue. I also updated today for this version 3.3.5. see my video of this issue http://www.avsim.com/topic/490798-phenom-300-problem-p3d-32/

Share this post


Link to post
Share on other sites

So it must not be installed properly OR you are not following the instructions in the Navigraph G1000 manual and the G1000 Phenom300 manual.  I used the Navigraph G1000 to learn to program the G1000.

 

If it is installed properly, you will see a SID when you select PROC then Departure (after entering an arrival and departure location in the FPL).  If you do not then it simply is not installed properly.  To change the SID and departure runway, you MUST use the GCU 477 Unit below the G1000.  It will not work using the inner and outer keys on the G1000. 

 

The GCU 477 is easier to use anyway.  You hit FPL and the FPL opens with a blinking cursor telling you to select a destination first.  You hit the inner or smaller knob twice and it opens a new window with a blinking cursor first and and a non-blinking cursor ready for input. On the GCU 477 you use the keyboard to enter your destination and then hit ENT.  Use your Outer Knob to move down to the blank line for departure.  Hit the inner or small knob twice and then use the keyboard on the GCU 477 and enter the departure location and then hit ENT.  You now have your to/from done.

 

Hit the PROC button.  Use outer/larger knob to move down to the Departure (I use the middle button on my Mouse to do this) and then hit ENT.  Use your outer knob to move down to the Departure SID.  Use the inner or small knob to scroll through the various SID's.  Once one is selected, hit ENT and your cursor will move to the takeoff runway.  Use the inner knob to scroll through the various runways and select ENT.  Your cursor will move to the Transition which you can scroll through using the inner knob.  Once selected, hit ENT and you will be taken to LOAD?.  Hit ENT.  Your departure is now complete.  Do the same for the Arrival.  All very simple and it works perfectly (using the GCU 477).

 

Again, if you do not see SID's when you move to Departure in the FPL, then your Navigraph Extension is not installed properly.

 

Apologize for the delay in responding.  Hope this helps.

 

 

hi, thkx for your reaction.

and no need to Apologize. you must me a buzy man on this forum.. i understand . for a moment i considered so many people are flying and no reaction ,

it scared the hell out of me for a moment... :nea::dance::hi:

but anyway...

 

i always used the GCU 477 but is not responding when start typing an ICAO.

Also no FLP showing in the FLP section when i load a FLP via P3D. everywhere shows NONE or 0. by PROC / DEP or APR

 

so looks more like NAVIGRAPH  is not installed correctly like you said

SO .. where is the right path than  ?

the installer installs it to: C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\CarenadoNavigraph.

if this is not the right path ,,than what is ??

when i install it WITHOUT the nav pack , all is oke (except no DEP )

i looked in to the manual of the g1000 but nothing is said about where the navigraph location  should be...

only what the soft keys or knobs do.

and i have bin flying other aircraft's with a g1000 so i know them

 

my dll.xml file looks like this :

  <Launch.Addon>

    <Name>carenavigraph</Name>

    <Disabled>False</Disabled>

    <Path>.C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\carenavigraph.dll</Path>

  </Launch.Addon>

 

the path where the actual path is where the cycle info is :

C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\CarenadoNavigraph\Navigraph\NavData\NavData

and at this moment it is 1607

 

i don't know what more information to give at this point .

so hoop you can solve my problem.   THKX IN ADVANCED !!

Share this post


Link to post
Share on other sites

 

 


so looks more like NAVIGRAPH is not installed correctly like you said

SO .. where is the right path than ?

the installer installs it to: C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\CarenadoNavigraph.

if this is not the right path ,,than what is ??

 

There are the required files and gauges too.  See my explanation at the following link - http://www.avsim.com/topic/490798-phenom-300-problem-p3d-32/?p=3444849

 

Best regards,

Share this post


Link to post
Share on other sites

i looked at all my folders and files and all where exactly the same installed. except for the navdata folder

in : CarenadoNavigraph /navdata. there was another folder named NAVDATA where the database was installed .

i copied all in the files back to the first navdata folder and now it look the same as yours.

a  hash also showing :(5dd05a27-e358-4545-b5fc-d22b706bb8f4)

 

when i opened it with notepath shows this :

 

<addon name="Carenado (all products)" guid="5dd05a27-e358-4545-b5fc-d22b706bb8f4" cycle="1607" revision="1">
  <mapping simulator="FSX">
    <directory name="NavData">
      <files destination="cycle_info.txt" source="9b7ad494-8450-436a-abd5-5ca0347c095f" />
      <files destination="Airports.txt" source="f56f2f21-da18-4019-9b55-5c699af7dc0f" />
      <files destination="ATS.txt" source="39b8dcaf-ca8d-4e71-ad8c-af30e7830e33" />
      <files destination="Navaids.txt" source="492926b4-cad8-4179-a2df-9f28343cbd91" />
      <files destination="Waypoints.txt" source="fd427619-014d-4df8-bdc9-204ab78e55d7" />
    </directory>
    <directory name="NavData">
      <directory name="Proc">
        <files destination="06FA.txt" source="bd38a662-e348-4b25-9178-40dca98c27ef" />
        <files destination="07FA.txt" source="48d0563a-a5ff-4ed9-8f65-e4e0f41c610d" />
        <files destination="0XA4.txt" source="a62fe134-f629-45c3-a370-9c4af8aac1bb" />
        <files destination="0XA5.txt" source="a1cb8f3f-058d-4e67-8bf6-a3d5265ec16e" />

      ect ect...

 

why shows by "<mapping simulator="FSX">" and not preperd v3 ?

i don't have FSX and i tried to changed it to PreparD v3 but no change.

 

further more i played around with the permission /security items . i set them all the same with full permission

(and removed the CREATOR OWNER ###### everywhere.) to all folders/subfolder and files on ALL installs in for instance : apdata, roaming, lock../ program files x86 / programdata

i find some navigraph folders and did there the same. but...... :mad:  still all the same...

 

is there some known other addon that could interfere whit the phenom ? or navigraph ?

 

don't know anymore what els to look for ... hoop you have some options still... :hi: :wink:

Share this post


Link to post
Share on other sites

 

 


why shows by "" and not preperd v3 ?
i don't have FSX and i tried to changed it to PreparD v3 but no change.

 

Mine shows that too.  P3D IS FSX only modified.  Navdata is navdata. 

 


CarenadoNavigraph /navdata. there was another folder named NAVDATA where the database was installed .

i copied all in the files back to the first navdata folder and now it look the same as yours.

 

Good for you.  Navigraph really has a hard time figuring out how to install navdata.  Sometimes it installs it into Prepar3d_v3/NavData and then NavData/Proc.  I just move the info all up to the Navigraph folder where it is read from.  If you have your navdata and files installed like how I showed in the link I provided, then you should have no problems whatsoever.  The next time you start up the Phenom 300 it will load the new navdata.

 

 

 


further more i played around with the permission /security items . i set them all the same with full permission
(and removed the CREATOR OWNER ###### everywhere.) to all folders/subfolder and files on ALL installs in for instance : apdata, roaming, lock../ program files x86 / programdata
i find some navigraph folders and did there the same. but...... :mad: still all the same...

 

I have no idea what you did here.  There is only one place where Carenado is installed and that inside the P3D Folder.  I do not have the file folder (my user name)/AppData/Roaming/Lockheed Martin/Program Files X86/ProgramData.  I do have a folder (my user name)/AppData/Roaming/ProgramData .  This folder has nothing to do with P3D or NavData and mine has one Windows file in it.

 

You should have a folder (your user name)/AppData/Roaming/Lockheed Martin/Prepar3D v3 and that folder contains your p3d.cfg, etc. It has absolutely no navdata.  This folder is normally hidden by your computer system so that one will not make changes to the files in it as it will mess up your computer system (and P3D) if you do the wrong things. 

Share this post


Link to post
Share on other sites

I am going on vacation for  2 weeks so when i get back and do a full clean install of P3D and install only the phenom , see what happens than and report back here .

 

thnkx for all the replies  !!

Share this post


Link to post
Share on other sites

 

 


why shows by "" and not preperd v3 ?

 

You'll have to ask Navigraph this question.  I do not think that has any affect on the installation as you map it to the location where P3D Navigraph is located.  The data is the same for FSX and P3D.  Here is the header for my latest Navigraph update:

 

 


<?xml version="1.0" encoding="utf-8"?>
<addon name="Carenado (all products)" guid="5dd05a27-e358-4545-b5fc-d22b706bb8f4" cycle="1608" revision="1">
  <mapping simulator="FSX">
    <directory name="NavData">
      <files destination="cycle_info.txt" source="983b714b-c517-4ec7-9cc2-234848ed86b1" />
      <files destination="Airports.txt" source="9143176b-e431-4935-a04e-8d5cd88f1a68" />
      <files destination="ATS.txt" source="d60d1d9d-73a6-4a59-977b-5c10c505ef60" />
      <files destination="Navaids.txt" source="982e948d-d921-4607-bea5-cc3719941101" />
      <files destination="Waypoints.txt" source="672109d7-ce4e-4098-ac4c-ce47d4ff61d8" />
    </directory>
    <directory name="NavData">
      <directory name="Proc">

 

 

 

 


is there some known other addon that could interfere whit the phenom ? or navigraph ?

 

No.  If there was then this would have been reported a long time ago.  You just have to map your location of the NavData to the proper location on your computer.  I recall I had to do this as the NavData was being installed in the same location as yours.  Just go into Navigraph and map it properly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now