Jump to content

Sign in to follow this  
GSalden

AM and cores load ( 6-core )

Recommended Posts

Hi all,

 

Today I am focusing on finetuning cores load and framerate.

 

 

Cores load

 

The affinity mask is set to 340 ( 00,01,01,01,01,00 )

 

This is how it looks when P3D is NOT running :

 

AM%20test%202.jpg

 

Here how it looks when P3D is running :

 

AM%20test%201.jpg

 

 

I was under the impression that P3D would start at core 2.

However it is core 0 that is loaded to the max...

 

When shutting down P3D the load on core 0 goes to a low level.

 

 

 

Framerate

 

To get the highest LOWEST framerate I use Unlimited.

At a very detailed airport with AI traffic and lots of clouds with framerates locked at 25 or 30 or 60 the framerate goes down to 17-22.

Using Unlimited the framerate is Always 25+..

 

So at the moment I am testing with the NVI framerate limiter , locked at 30, to see if that helps. 

On the ground I still have my 25+ and the moment the framerate is able to go above 30 it is limited to 30.

 

As I have some jittering when making large turns above clouds I now am going to test with the NVI framerate limiter to see if that might help.   

The moment the jittering occurs ( Unlimited ) I can see the framerate go up/down between 28-55.So perhaps the NVI limiter might help with that.

 

Regards,

Gerard


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post

It would be nice to know if someone with a 6 core and running affintitymask through Prosess lasso produces the same graphical result.

Does the graph and the *core indicators check boxes look the same in Task manager, btw did you enter the affinitymask in the .cfg file on the fly, the reason I ask is some entries need a restart of p3d.

 

bob

 

edited *

Share this post


Link to post

Hi Bob,

 

With each mod I make in the p3d.cfg file I restart P3D.

 

I also have Process Lasso.

All P3D cores enabled in Process Lasso.

 

Tried it running beside P3D and ran P3D with Process Lasso Not running.

No difference in cores load of P3D ( with AM=340 ) .

 

Regards,


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post

Hi Bob,

 

With each mod I make in the p3d.cfg file I restart P3D.

 

I also have Process Lasso.

All P3D cores enabled in Process Lasso.

 

Tried it running beside P3D and ran P3D with Process Lasso Not running.

No difference in cores load of P3D ( with AM=340 ) .

 

Regards,

 

Hi Gerrard, did the 'Processor Affinity' settings in the ' set affinity' pop up for P3d.exe  in task manager match the 340 ( 00,01,01,01,01,00 ) ie were the cores indicated.( boxes ticked)

 

bob

Share this post


Link to post

In the taskmanager all 12 cores are enabled for P3D, but that is because the AM is working outside the taskmanager. ( as far as I know. Steve ? ? )

 

I deleted the AM entry and restarted P3D.

Then in the Taskmanager I set the cores like AM=340.

 

Last time I checked it worked but I was using W 7 64,

Now I am running W 10 64..., ( can this be a cause..? )

 

This is how it looks :

 

AM%20test%203.jpg


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post

 

 


In the taskmanager all 12 cores are enabled for P3D, but that is because the AM is working outside the taskmanager. ( as far as I know. Steve ? ? )

 

on my 4 core, (w7) its always seem to match, but will check again, your right we need Steve to jump in.

 

bob

Share this post


Link to post

Just found the cause of my issue. In the p3d.cfg file I made last week I made a writing error " [JOBSCHEDULER}   --> instead of ]

 

AM immediately worked :

 

AM%20test%204.jpg

 

 

AA

 

In the meantime I am doing tests with AA.

​As I have a Titan X I have a lot of GPU power. However I use 3 screens for 1 wide outside view.

 

Test scenario ; 3 cloudlayers 7/8 - photoscenery + custom ag ( Amsterdam with EHAM + AI traffic insight too )

 

MSAA 8x --> max load on GPU 86% / Memory control load max 34%

MSAA 4x --> max load on GPU 65% 

MSAA 2x + SGSS 2x --> max load on GPU 67%

MSAA 4x + SGXX 4x --> max load on GPU 99% / Memory control load max 44% 

   

A little less clouds and the gPU goes down to 88-95%. Also the clockspeed goes down then.

I will try a complete flight with 4x MSAA + 4x SGSS and see how it goes...

 

@Steve :

I had my Fs addons use Cores  0, 10,11  ( not running in the screenshot above ! )

Now I have assigned them all to 0,1,10,11

 

This is how it looks :

 

AM%20test%205.jpg

 

 

 

Thanks,


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post

Great news Gerard, your eyes are better than mine, would never have spotted that. 

bob

Share this post


Link to post

I only saw it after I posted it here....

 

One thing I remarked : when I have everything running and I open up the task manager , within 15 seconds P3D CTD.

If I do not use the task manager everything is running fine.

 

If I only run P3d and then open the task manager no CTD...

 

Everything look great now :

 

EHAM%203.jpg


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,560.00 of $25,000.00 Donate Now
×
×
  • Create New...