Sign in to follow this  
JLSeagull

Program Pin Error

Recommended Posts

Is anyone else getting this seemingly random error when selecting the Departure or Arrival in the FMC?

 

Regards,

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Is it random or can you find a reproducible sequence of steps to evoke the pin error?

 

This error message is the PMDG runtime module announcing that the program has encountered an unexpected condition.  If you can provide the steps to recreate then it's be possible to isolate if this is corrupt navdata or internal.

 

Second thought:  If you updated to 1602 navdata on the day it came out try downloading 1602 again..., there was a problem with their download on day one which was fixed and all good now.

Share this post


Link to post
Share on other sites

I've had this many times and I'm fairly certain it's to do with corrupted NAV data.

Share this post


Link to post
Share on other sites

I've had this many times and I'm fairly certain it's to do with corrupted NAV data.

Sorry to contradict you on this one Mike.(and I am NOT knocking PATC - because it is an absolutely amazing ATC AddOn), but - after encountering multiple Program Pin Error frustrations - I have re-installed P3D, PFPX, Aivlasoft EFB, Navigraph 1602 (current), NGX and ProAtc-X

 

Creating a flight in PATC and saving it (and also saving the exact same ATC Route in PFPX and exporting it to PMDG) results in two optional CoRoutes appearing in the FMC (Bear in mind that BOTH are identical Routes)..

 

For example: LEPALOWW01 (which is a standard .rte file that the PMDG FMC understands) and - LEPALOWWCLR which is a ProATC-X generated Flight Plan.

 

If I select the LEPALOWWCLR. route then I get a Program Pin Error when selecting the Departure from LEPA.

 

.... After ReBoot.....

 

If I select the LEPALOWW01 route then the FMC behaves as it should and I can complete the flight,

 

Yes! I have re-downloaded the latest (1602) Airac and Yes! I have executed the entire Patc Airac Import and Scenery Alignment Routine.

 

 

Surely this must suggest that there is a slight glitch in the way that PATC writes the route to the PMDG Flightplan?

 

Commas instead of seperators perhaps? Just a thought.

 

Regards,

Share this post


Link to post
Share on other sites

Hi mate, yes, I have also had this with PATC, quite a few times actually. But, I have also had it happen many times without PATC, as have quite a few other simmers. So I still believe it's something to do with the NAV data, AIRAC etc.

Share this post


Link to post
Share on other sites

Hi mate, yes, I have also had this with PATC, quite a few times actually. But, I have also had it happen many times without PATC, as have quite a few other simmers. So I still believe it's something to do with the NAV data, AIRAC etc.

Hopefully, when Navigraph release the new Airac Cycle tomorrow, this problem will resolve itself. It has been driving me bonkers for the last couple of weeks Mike!!

Share this post


Link to post
Share on other sites

I use Aivlasoft EFB, which always gives me the first hint that something is about to go awry. It's always to do with FSX/P3D's runways, for example, I kept getting the old runway alignments at Stansted, every time I used the NGX there, it threw up a PPE, I then installed the latest MAGDEC from Herve Sors and all is well again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this