Sign in to follow this  
Richard980

Low performance (i5 6600K & 2xHD 7870XT)

Recommended Posts

Hi everyone

 

Last time I've low frame rate on Prepar3d V3.1. I search online for tweaks and tips to improve my frame rate. But nothing helped really.

When I start with a flight my frame rate is around 20-30 FPS. But when I takeoff it drops to 8-12 FPS and it does not rise anymore.

 

The settings on P3D I played from low to medium and even high, but there is no big different. Only around 2 frame rates. Also I tried it with Active Sky Next, but there is no really different between 2 and 5 layers. I've also looked at REX Texture Direct but this was already at low.

 

Someone an idea what is wrong or an (hidden) setting what I maybe missed?

 

Richard

 

Scenery:

  • NL2000
  • UK2000
  • FlyTampa St. Maarten
  • FlyTampa Tampa Rebooted
  • TropicalSim Curaçao
  • FS Dream Tech New York V2

Add-ons:

  • Active Sky Next
  • REX Texture Directs
  • EZdok
  • Ultimate Traffic 2

PC Specs:

  • i5 6600K
  • MSI Gaming M5 Z170A
  • 2x HD7870XT

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

What are your in game settings? There is something definitely off. Have you tried disabling crossfire for your GPUs?

Share this post


Link to post

No Crossfire is not the problem because I play it windowed, and crossfire required full screen. To be sure I've disabled it, but really no differences.

 

What do you mean exactly with in game settings? All my settings for display of my game?

Share this post


Link to post

No Crossfire is not the problem because I play it windowed, and crossfire required full screen. To be sure I've disabled it, but really no differences.

 

What do you mean exactly with in game settings? All my settings for display of my game?

 

Yes. There must be something there that's causing this issue. Have you been monitoring your GPU usage while it game? If its pegged at 99% then that may be it. Your cards are a little old to be honest. They may not hold up especially with the newer drivers. You have updated your drivers right?

Share this post


Link to post

I have the newest drivers, and the GPU load is between 40-60% at default clock. To remind you I've already played with those settings but it make really no differences. But you can always take a look if I missed something. :smile:

 

BTW, in the future (4-5 months) is a GPU upgrade planed and a new monitor. So if this really the problem I can do it early. But the low FPS I've it the last time, a few months ago it was stable at 30-40 FPS. So I think its not my hardware, and flying is not relaxed anymore. Because this I've canceled my long flights. :sad:

[EDIT]

I see now that how lower the frames, how lower the GPU load.

Lets say around 20-30 FPS the GPU load is 50-60%. And around 10FPS it is around 35-40% load.

 

My in game settings:

 

P3D_settings_1.png

P3D_settings_2.pngP3D_settings_3.pngP3D_settings_4.pngP3D_settings_5.png

 

Edited by Richard980

Share this post


Link to post

Hmm, yeah that's very low settings. How about Global Vector settings? I think it may be something else entirely? I know it should be the last resort, but have you tried reinstalling everything? Is your 6600k overclocked?

 

I had a problem with another game where the C-states/Speedstep was kicking in while I was in the game and the processor downclocked to half speed.

 

Disabling that solved the issue. You might wanna check your CPU load and clock speeds when the phenomenon happens if you haven't already.

Share this post


Link to post

Two Suggestions - Make sure Windows Aero is NOT  Turned on ! - Next - IF You have Your O/S and P3d on the same Drive - Disconnect the Additional Drive - It Could be a Weak Power Supply - Johnman B)

Share this post


Link to post

I'd disable ALL add-ons and scenery or do a complete P3D reinstall. Leave everything alone. See what you get with a default install. Then start reinstalling the add-ons.

 

Probably before a complete reinstall, locate the dll.xml files and rename them. Rename the prepar3d.cfg file so you start clean.

 

Test and add back the dll.xml entries one at a time - add the add-ons, one at a time.

 

 

Vic

Share this post


Link to post

Hmm, yeah that's very low settings. How about Global Vector settings? I think it may be something else entirely? I know it should be the last resort, but have you tried reinstalling everything? Is your 6600k overclocked?

 

I had a problem with another game where the C-states/Speedstep was kicking in while I was in the game and the processor downclocked to half speed.

 

Disabling that solved the issue. You might wanna check your CPU load and clock speeds when the phenomenon happens if you haven't already.

 

I don't have FTX Global Vectors yet. And it's look like I don't have that issue.

 

Two Suggestions - Make sure Windows Aero is NOT  Turned on ! - Next - IF You have Your O/S and P3d on the same Drive - Disconnect the Additional Drive - It Could be a Weak Power Supply - Johnman B)

 

I've Windows 10, there is one theme. No, I've a 750 watt PSU and that is enough. I've have perform an benchmark on this system (both GPU's 100%) and no problems. And P3D use one GPU so this 100% sure not the problem.

 

I'd disable ALL add-ons and scenery or do a complete P3D reinstall. Leave everything alone. See what you get with a default install. Then start reinstalling the add-ons.

 

Probably before a complete reinstall, locate the dll.xml files and rename them. Rename the prepar3d.cfg file so you start clean.

 

Test and add back the dll.xml entries one at a time - add the add-ons, one at a time.

 

 

Vic

 

Good suggestion. But my plan was in the future to set P3D on a own SSD, and because a shortage of disk space I'm going reinstalling P3D on an own disk.

Share this post


Link to post

In the meantime I have reinstalled P3D, add-ons and almost all my aircraft's and scenery's. Only Texture Directs is not installed.

 

Now I don't have anymore the performance issues. I think that my VRAM (2GB GDDR5) the bottleneck is. Because without Texture Direct my VRAM is on 98%. On the ground my framerate is now 30-40 and after takeoff and minutes after it the same. Only a few differences on my settings: ASN is now on default settings. Also now the GPU load is now around 70-90%, now is my GPU doing a job. :smile:

 

In three months I going to upgrade my GPU to an R9 390X (AMD fan here). :smile:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this