Sign in to follow this  
Denco

X52 Pro MFD Radio Stack help on FSX SE

Recommended Posts

Hi,


 


I can't get the MFD to show radio stack on my x52 pro. I've downloaded the plugin and checked the exe.xml file if all the entries are there. Even with everything as it should be and "SaiFlightSimX.exe" running when I start up the sim my MFD is still not showing radio stacks. I've also tried stopping and re enabling Saitek DirectOutput service.


Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What rev of X52 Pro driver are you using? The most recent sliced off the MDF radio stack stuff into a "plug-in" which has unique variants for either FSX:MS, FSX:SE or P3D. Hopefully you are using the appropriate driver rev/plug-in for FSX:SE. Unfortunately the X52 driver can be is a huge pain, and I really don't have any specific advice except to uninstall everything associated with the X52 and start over with everything at the latest rev from Saitek; your profiles will not be unistalled by this, which is a good thing for they are not the issue. Beware that USB 3 and these drivers don't get along at all, but hopefully that should not be an issue with your SB system (no USB 3...right?).

Also note I abandoned using the FSX MDF stuff for it causes stutters in FSX unless appropriate affinity mask settings are employed, either internally to FSX or externally to the MDF app. I used the MDF so infrequently I decide the MDF stuff was not worth this associated overhead and was glad when the latest driver made its use optional.

Share this post


Link to post
Share on other sites
I've managed to get it working by updating Saitek drivers. 

 

Sadly my joystick gets this weird light flickering ( which I usually have set to off ) and looses calibration when using the MFD with FSX.

 

In the end I had to delete the calibration fields in the registry and I deleted the plugin software.

 

Thx for the help anyway Gonemad :)

 

Regards

Share this post


Link to post
Share on other sites

Just a guess, but maybe the USB port you're using can't supply enough power to drive the MDF.  I've had USB related power issues with my X52 pro which caused calibration problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this