Sign in to follow this  
MaxXP

X-Plane 10.45 Win10x64 v1.4 works fine v2.008 not quite so good

Recommended Posts

Hi Dave,

 

I have a Win10x64 pc dedicated to Pilot2ATC with its own display. This set up works in all respects in my multi pc cockpit over a network with X-Plane 10.45 when I run Pilot2ATC v1.43. The voice control etc works fine with great recognition.

 

I have installed v2.008 into a separate folder at the root of C and Pilot2ATC starts fine and communicates with XP. It reads radio frequencies, it can write the altitude and climb rate to the AP BUT it won't load the grammar files nor will it put the yellow plane icon on the map and move the map. If I continually click on the "centre map on aircraft" button the map moves and centres the position of the aircraft at the red cross but it won't do this on its own.

 

I am able to create a flight plan and file it but the voice comms won't work without the grammar. So I am stuck with v1.43 which is fine, but I would love to get all the benefits of the new version.

 

Any troubleshooting advice would be greatly appreciated.

 

Ted

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Ted,

First, I assume you installed the base product V2.0.0.1 first, then updated to 2.0.0.8.  (We're on 2.0.0.11 now, but that wouldn't affect the basic setup issue you are now having). 

 

When you first press the Connect button, I assume you are getting two messages in aqua color in the Speech window:

Simulator Connected

Recognition Engine Installed

 

Is that correct?  Or are you only getting the first one?  Or None?

 

Next, in order for the Grammars to Load, P2A requires Read/Write access to the subfolders in the installation folder, so check the folder security settings and be sure they are Read/Write for all users.

 

I'll wait to hear back before going further.

Dave

Share this post


Link to post
Share on other sites

Thanks Dave.

 

I uninstalled and started again. I installed 2.001 in the default location, and ran it as administrator. Closed. Changed the folder permissions so the Pilot2ATC user had full modify rights. I didn't update it to 2.011. Ran it again as admin, the Speech window only has the Simulator Connected message (nothing else) and the behaviour with the aircraft icon not showing/not moving remains.

 

I closed the program and started 1.43 immediately afterwards and everything is fine - moving map, loading grammar etc.

 

I thought the folder permissions would fix it, but sadly not.

 

Ted

Share this post


Link to post
Share on other sites

Hi Ted.

Since V1 works completely, I'll assume you have the US English Language pack installed as the default language and that your microphone is set up as the default Windows recording device.  Lacking either of these would prevent getting past the Simulator Connected message.

 

Here's a couple other things to check, without trying to Connect to the SIM. 

1) To confirm that the database engine is working, zoom in on an area about the size of Florida or half the size of the UK.  Click on the Airports icon (Far left button under the Map).  See if the Airports show up on the map after a few seconds.  You can try the VORs also.  If this works, then your SQL DB installation is working and probably not the cause of the connection problem.

2) Change your Aircraft call sign to:

       Mfg: Beech

Tail Number: N431VB

Do Not spell out the letters or numbers

3) Press the Grmr Help button on the far right of the screen.  It will open the Grammar practice window.  Press the Practice button, and see if it changes to Practicing.  If so, using the Large PTT button on the screen, try saying "Say Altimeter".  It should appear in the Practice Speech window above the button.

 

Now, before trying to connect do the following

1) In the config panel, P2A Setup tab, be sure the "Play Tone" check is Unchecked in the Speech Recognized Tone box.

2)On the Speech Tab of Config, set all three Speech Recognition Settings to Zero (0).  This will give them the default values.

3) If you don't have voices set up on the Voice tab, leave it that way...all blank.  If you do have voices set up on the Voices tab, press the Tst button for each one to be sure they all work properly,  If not, set the ones that don't work to voices that do.

4) Clear all hot key and Joystick Button settings

     P2A Setup Tab: PTT Hot Key, press Clear Button (Check that the Joystick device and button are valid)

                Minimize Hot Key - Clear

   Speech Tab: Sayit HotKey and Joystick Button - Clear

5) Sounds Tab, Clear all entries on this tab.

 

All of this should remove any extraneous settings that might lead to a faulty connect. 

With fingers crossed, and the SIM running, Press the Connect Button.

 

Get back with the results.

 

Thanks,

Dave

Share this post


Link to post
Share on other sites

Thanks for helping me, Dave.

 

I have fixed it. The clue was changing the call sign. When I changed it in Config, it didn't change in the info window at the bottom. So after installing/uninstalling a few times and getting the SQL dB id error, I figured that the dB settings were in the registry somewhere. It was it that point that I uninstalled again and this time installed using the same folder name I used when I first installed it. Now it is working in all respects including the yellow plane icon.

 

Thank you for pointing me in the right direction.

 

If anyone else is reading this here are a few tips:

Install with administrator privileges

Don't simply delete the Pilot2ATC folder, use the uninstaller in the folder

Don't install the new 2.0 version over the old 1.4 - uninstall the old one first

Let Pilot2ATC install into its default folder

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this