Sign in to follow this  
1G5

Monitor in Portrait Mode

Recommended Posts

I'm new to the site and I'm in the process of setting up multiple monitors.  On my glass cockpit, i have three touch screen monitors.  I'm able to get them all to work just fine, but I would like one of them to operate in "portrait" mode.  When I rotate my monitor in the set-up in my nvidia card, then go to display settings in fsx the display is not recognized.  Rotate it back and fsx sees it just fine.  Does anyone know how to set just one screen up in portrait mode, all others will operate in landscape mode???


 


Thanks in advance for your help.


 


Tim 


Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You don't give any screen details, but I had this problem when I tried using a 10 inch 1024x768 touchscreen in portrait mode for the CDU in my own cockpit. I use P3d, but I think FSX has the same issue.

For monitors to be recognised correctly it is usually necessary to have the same resolution set in the video card controller panel and in the simulator settings. The Nvidia control panel was no problem, but I found that  the simulator will only recognise certain resolutions in portrait mode. There seems to be a minimum 'lateral' resolution of 1024.

 

In the simulator it only worked in landscape mode and was not recognised in portrait mode.  I then experimented with different screen controller hardware, but it seemed that the native resolution of the lcd panel was simply too low.

 

The solution was to use ebay to source a new high resolution 10 inch touchscreen and controller kit from China. It will accept input resolutions up to 1920x1200, although the true native resolution is rather less than that. It worked immediately in portrait mode and allows a choice of resolutions. As a bonus the screen image is sharper and the touch inputs seem to be more sensitive than the old panel.

 

jbee.

 

Share this post


Link to post
Share on other sites

jbee,

 

the monitor I have is a new ELO 1002L with a max display rate of HD 1280 x 720, the nvidia card allows it to be configured in portrait mode just fine.  how does changing the resolution, help FSX see it in portrait mode?

Share this post


Link to post
Share on other sites

Tim,

I've just noticed that this post is in the main FSX forum. It should probably be in the Monitors subforum, so you may well find the mods will move it there, and you may get more expert responses.

 

Regarding the resolution, as I said, there seems to be a minimum 'lateral' resolution that FSX (and P3D) will recognise in portrait mode, and from experience is somewhere above 768.  In your case the monitor has a 'lateral' resolution of 720 in this mode, which is not being recognised by FSX. 1024 and upwards seems to be OK. To prove this, if you have a spare monitor with a resolution like 1280x1024 or 1960x1080 just try it in portrait mode. Those resolutions will work, although it won't help with your problem.

 

I would suggest checking in Nvidia control panel to see if you can set an input resolution higher than the native resolution.  The Nvidia software tries to identify acceptable resolutions, to avoid damaging monitors by overdriving them, so it may or may not allow a higher setting. If you are able to set a higher resolution in the Nvidia controller, then check again to see if FSX will now recognise the card. Before doing this, open the FSX.cfg file and look for any entries for this ELO monitor and delete them. You may not find any.  The entries for the other monitors can be left. If FSX recognises the ELO monitor it will add an entry to the FSX.cfg.

 

jbee.

Share this post


Link to post
Share on other sites

I think in order for this to work your total resolution set i. Display has to be something that covers ALL monitors... If for example (stating non-real examples) the landscape monitors have a vertical res of 1080 and the portrait mode one will be 1920 you need to set it to 1920 tocover all, with so e parts being hidden later (as the landscape ones won't show part). You'd be better off going to either AMD or Nvidia sites to check mukti display setup, I have found it's pretty nice,y detailed

Share this post


Link to post
Share on other sites

Carlos,

 

I took it from the original post, referring to touch screens in a glass cockpit, that we are dealing with separate undocked screens used as part of the instrument display. I assumed the outside display was additional to these.  If I have misunderstood this perhaps Tim can confirm how the screens are being used. 

 

With undocked panels on individual screens, each screen can have its own resolution according to the monitor used, providing it's within a range which is recognised by FSX.  Each undocked panel is then sized to fit its own screen. This is quite different to using 3 monitors for a single spanned outside view.

 

jbee.

Share this post


Link to post
Share on other sites

All,

 

Thanks for the direction.  

 

The solution was to go into the nvidia resolution setting and customize the display setting to 1920 x 1200, rotate the screen to portrait and all is good.

 

This drove me crazy...but I got it.

 

Thanks to all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this