Sign in to follow this  
maggsy63

speech recognition problem

Recommended Posts

I am at a loss atm with P2ATC 2.0.0.18 (and even tried  v1.4.3.6) not able to recognise anything I say.

I recently had to rebuild my pc with new SSD's and clean install of win 10 64bit.

Since then I have tried eveything to get P2atc to work.. it installs with no problem it connects to X-Plane 10 it just does not recognise my input through the mic.

I have both Eng uk   and Eng US language packs installed

the mic is the same one that worked previously (Razer Kraken 7.0) it is set as default both for playback (headphones) and Record (Mic) if the Listen option is applied it is picking up my  voice cleanly with little or no other sounds.  I have run the  windows mic setup with it performing perfectly.

I have tried both Eng UK  and Eng US as the chosen language and ticked/unticked the recognise non-native accents  for this language.

 

Within P2atc V 1.4.3.6 the PTT works ( joystick button and even KB key assigned)

Selecting TST creates popup window.

 

Speech Recognizers Available

Installed Speech Recognisers

en-GB Desc: Microsoft Speech Recognizer 8.0 for windows (English-UK)

en-US Desc: Microsoft Speech Recognizer 8.0 for windows (English-US)

Click ok

Popup window

You are not connected to the simulator

Click the ? key and the frm Grammar window pops up

click practice

popup window confirms:

Recognition Engine Installed:en-US

Grammars successfully loaded. Call sign is:speedbird Two Zero

 

I have tried saying the various examples in the lefthand window but with no success  using the PTT button and mouse after selecting practise and it changing to practising

I have tried the default callsign Beech One Victor Bravo with the same lack of success.

 

I have entered config and trouble shooting

Installed Speech Recognizers

en-GB Desc...etc

en-US Desc...etc

selected Testing Speech

active speech recognizer: en-US

but nothing happens when I press the PTT butting with the mouse.

 

Using P2Atc 2.0.0.18 has the same reaction with the exception the use of the mouse to press the PTT button on the gui results in P2atc (not reposonding)

 

I am certain it is a user config problem and I am failing to setup the hardware in some way but cannot figure out what I am doing wrong any help would be appreciated

Maggsy

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Maggsy,

I suggest we stick with the Grammar Helper and get it working before testing anything else.  I went through the steps you describe in opening and using Grammar Helper in V1 and get all the same messages (except the GB English recognizer installed one).  So it seems you have the language and recognizers all set up correctly.  The big difference is that my voice is recognized.

 

So here some things to check/try

1) Make sure you microphone is not muted.  Since the Listen function in the sound setup is letting you hear sounds from the Mic, the physical mute is obviously off.  See if the volume setting is turned up both on the headset and in windows.

2) When you right click on the Speaker in the task bar and open the Sound dialog, go to the Recording tab, select the headset and be sure the "Set Default" button is grayed out.  If not, press it.  These sometimes get reset....I don't know how.

3) Using Grammar Helper, try saying just "Say Altimeter".  That is the simplest phrase it can understand and is not influenced by the call sign.

 

Let us know what happens.

Dave

Share this post


Link to post
Share on other sites

Alas no joy

mic is default with the option greyed out.

all levels are at around 50% including P2A Grammar Helper when its selected and Pilot 2 ATC v 2.0.0.18 MFD when Grammer Helper is not being used.

 

I have tried a different mic (one fitted to a web cam borrowed from another PC and tested to show it works).

Using Grammer helper in the txt box the only thing that appears is the words Full Txt: in green appears when PTT is released.

I tried it with x-plane running and connected, the Radio test works..

I have also tried P2atc alone the results are the same.

Stumped at the moment for ideas it is something simple I am not seeing ..

Maggsy

Share this post


Link to post
Share on other sites

Maggsy,

Another thing that worked for a user with an adjustable sound card who could not get his voice recognition to work. 

He changed the sample rate from the default of 48kHz to 44.1Khz and it started working.  No one knows why this worked, but it did.

 

Dave

Share this post


Link to post
Share on other sites

I have found the solution,

I cannot take the credit.. I was reading other bug reports for any clues and came across one that suggested running P2ATC as admin.... Bingo worked straight away ..

I was lost without this program I really enjoy the flight sim a whole lot more using P2ATC so glad its back up and running

 

 

again the solution to my issue was to right click on the Pilot2ATC_200.exe and select run as administrator.

Thanks for your help Dave

 

Maggsy63

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this