Sign in to follow this  
WB_FlashOver

2.7.0 On Repeat very slow

Recommended Posts

Hello developers,

First let me say thanks again for the great program. Each revision gets better. 

 

I am having issues with 2.7.0 with On Repeat commands though. 2.6.8 would give very smooth and steady trim adjustments where 2.7.0 is jumpy with about 1/2 second pauses between wheel movements. This is happening on a friends PC as well but he's on Win 7 Pro 64.

 

FSX & FSX-SE, Win 10 Pro 64, Saitek X52 Pro, FSUIPC4 v4.949. 

 

Looking forward to more flying with LINDA.

 

FlashO

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Well, belay my last. I reinstalled 2.6.7 and 2.6.8 and then 2.7.0 again and for some reason it is better. The A2A P51 is still jumpy but it always has been. Last night the A2A B17 was terrible but after reinstalling it is smooth again. I followed instructions of removing linda & linda-cfg folders as well as ipcReady.lua, LINDA.exe and linda.lua and then placing the new files/folders into the modules folder.

 

Thanks again

FlashO

Share this post


Link to post
Share on other sites

There's a bug in the latest version where LINDA doesn't finish initializing until you go to the Joystick page.  So, if it happens again, give that a try and see if it clears up.  The dev knows about it and plans to work on it when he gets back next month.

Share this post


Link to post
Share on other sites

Thank you Gregg,

I had made a habit of syncing twice and clicking the joystick page on versions prior to 2.6.8 but on 2.6.8 it was working without doing this. So maybe for the time being I need to go back to my normal startup steps.

 

Thanks again for the reply.

FlashO

Share this post


Link to post
Share on other sites

Hi Guys

 

Many thanks for the report and for the self help. There were some necessary changes to the OnRepeat mechanisation to remove a risk of runaway where the OnRpeat was not cancelling correctly OnRelease. Gregg is correct about a bug that the Lua Engine must be restarted or the Joystick page selected if loading from a saved flight or scenario.

 

Flashover, to help me, how do you have the trim assigned. Are using a HAT or trim wheel?

Share this post


Link to post
Share on other sites

Hello Scot,

Thanks for the reply Sir. Tonight it is back to very very jumpy and slow. I have trim set on the index finger hat switch on my throttle hand on the X52 pro. I have up/dn fast un-shifted and up/dn regular shifted. I've tried reloading Lua engine, no joy. I've tried selecting Joystick page, no joy. I've tried multiple syncing, no joy. I have tried restarting LINDA, no joy. For now I have trim set in FSUIPC. I'm sure you will have it ready for the next release.

 

This truly is a great program and I'm very appreciative for it. Hats off to you.

 

FlashO

Share this post


Link to post
Share on other sites

It'll be good when this is fixed.  I have some custom trim scripts here and there to make the wheel speed more realistic on some airplanes.  I'd just as soon not mess with custom LUA scripts...the LINDA editor is so nice!

Share this post


Link to post
Share on other sites

I suppose it's not needed to mention this as it is a OnRepeat issue but it is not just the trim. My cabin vent control and radio volume controls in the A2A B17 are just as jumpy and slow. 

 

FlashO

Share this post


Link to post
Share on other sites

The OnRepeat has never be recommended for rapidly repeating functions (like thrust reverse) with FSUIPC4 providing a more reliable option. It comes from the 1Hz timer used by LINDA which is a compromise between processor load and responsiveness. I am also balancing LINDA with other apps like FS2Crew. I will investigate in a couple of weeks when I get back to the UK.

Share this post


Link to post
Share on other sites

Hello Scot,

Just curious about this slow repeat issue. I'm sure you're busy so I'm just checking in. 

Have a great day.

FlashO

Share this post


Link to post
Share on other sites

Hello Scot,

Just curious about this slow repeat issue. I'm sure you're busy so I'm just checking in. 

Have a great day.

FlashO

I have no update for you. I have the 'real world' getting in the way of pleasure (programming).

Share this post


Link to post
Share on other sites

I have no update for you. I have the 'real world' getting in the way of pleasure (programming).

LOL Scot, I know what you speak of. Real World really gets in the way of playing...(programming). In your time Sir. No worries.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this