Jump to content

Sign in to follow this  
Wanthuyr Filho

External Camera

Recommended Posts

I just tried creating an external camera (probably just setting it up, as it seems to be created by default), but the arrows for positioning just don't work, they won't move the camera, which will be stationary behind the aircraft. What did I miss?

Also, when I'm using another camera, such as the Top View/Mao View and then go to my cockpit/captain camera created with OpusFSI, there's a kind of transition like if the camera was tilted upwards and transitions to the "front" view by tilting down (pitch down movement of the camera). Is there any way to avoid this movement and go directly to the camera correct position? In these cases ("transition" from other cameras to internal VC cameras) I think there should be no transition movements to be realistic.

Thanks!


Best regards,

 

Wanthuyr Filho

 

qpwqa8-6.png

Share this post


Link to post
Share on other sites

If using P3D then you must install the latest beta as there is a bug in the LM PDK interface which prevents eye point control for all external views (see our SimForums P3D bug reports). The latest beta will use SimConnect for 6DOF to external views.

 

The transition time can be adjusted in the camera edit dialog for each view. Set to 0 to snap to the new view instead of transitioning.

 

Stephen :-)

Share this post


Link to post
Share on other sites

If using P3D then you must install the latest beta as there is a bug in the LM PDK interface which prevents eye point control for all external views (see our SimForums P3D bug reports). The latest beta will use SimConnect for 6DOF to external views.

 

The transition time can be adjusted in the camera edit dialog for each view. Set to 0 to snap to the new view instead of transitioning.

 

Stephen :-)

 

For number 1 OK, thanks!

For number 2 that's not what I desire, I like the transitions, they're very realistic, what I don't think is realistic at all is transitioning when you go from one external camera (in my example the Top View/Map View) to one VC camara created by OpusFSI...


Best regards,

 

Wanthuyr Filho

 

qpwqa8-6.png

Share this post


Link to post
Share on other sites

As I said eye point control in external views does not work in the PDK. It's also not possible to control the eye point at all in anything other than VC, 2D, and external views. The sims own top down and other views cannot be controlled, nor can the eye point be determined. It is simply impossible to transition from these views or between one view mode and another.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Stephen,

I updated to the latest beta, and now this "Weather Updated XXXXXX - Live" keeps popping up within P3D and I don't want this to happen. How can I prevent this?

Thanks.


Best regards,

 

Wanthuyr Filho

 

qpwqa8-6.png

Share this post


Link to post
Share on other sites

You cannot turn that off. It only pops up before flight when it downloads and decodes the GRIB data, it keeps you informed of its progress. After which you can then check the local, en route, destination, and upper winds before closing it using the Close option in its main menu.

 

Stephen

There is also another P3D v3 issue that causes the (all) menu style Windows to flash when updated. This is due to LM using a solid grey colour to clear its display prior to update.

 

Stephen

Share this post


Link to post
Share on other sites

So every time it loads GRIB data it will be shown?! In FSX I never had such popup and if possible I would like to keep not receiving it, maybe there should be an option for the ones who would and wouldn't like to see it. :-)

Stephen, I was setting up OpusFSI most of the night and now it stopped responding my button presses, or at least is delaying for many minutes, and I noticed that unchecking the option of using the P3D .DLL (that's using SimConnect then, right?) it started working properly again. I double checked by ticking the .DLL option again and it really stopped working, not it's not ticked. I'm using the beta downloaded today. I was able to create a whole new sequence, and adjusting some cameras too, before it started happening. Probably it has nothing to do with it, but I load the Action! software just before the problem arose.

Thanks.


Best regards,

 

Wanthuyr Filho

 

qpwqa8-6.png

Share this post


Link to post
Share on other sites

The pop up was introduced on customers request many blue moons ago and prevents GRIB problems going unnoticed. As I said there are problems at the LM end for the PDK. Make sure you have copied the latest and relevent OpusPDK DLL library into your sims Modules folder. The latest beta needs its DLL for the PDK. If possible you want to use the PDK with the latest beta as the PDK was introduced by LM to overcome problems and speed issues with their SimConnect processing.

 

There are no other PDK problems reported with the latest beta but you must copy the latest v2 or v3 DLL from your OpusFSI folder.

 

Stephen

Share this post


Link to post
Share on other sites

Indeed, I didn't copy anything today, I just uninstalled the previous version and then installed the beta on top of it, but no manual copy of any files whatsoever. That's wrong, right?! :-) I will look for the latest .DLL and copy it there. Maybe it would be a good thing if the installed copied it automatically.

Thanks again.


Best regards,

 

Wanthuyr Filho

 

qpwqa8-6.png

Share this post


Link to post
Share on other sites

There are problems doing that as it is needed in your sims Modules folder which the installer may not have access to. I always mention in SimForum Announcements if it needs updating, which is rare, and I also mentioned it in the Release notes which I know is not ideal.

 

Stephen

Share this post


Link to post
Share on other sites

Stephen, I copied the P3D V3 .DLL from the OpusFSI folder - which I assume is the latest version together with the latest beta version, but the issue still remains. I need to revert to SimConnect if I want to use the cameras...


Just to make sure, does it make a difference loading OpusFSI executable either via EXE.XML or FSUIPC?


Best regards,

 

Wanthuyr Filho

 

qpwqa8-6.png

Share this post


Link to post
Share on other sites

The SPY window will report joystick button presses (which I have assigned to cameras) with ***many seconds*** in delay and nothing happens. Up there it says that it is connected to the simulator AND is connected to the OpusPDK as well.


Best regards,

 

Wanthuyr Filho

 

qpwqa8-6.png

Share this post


Link to post
Share on other sites

The button/key events all come from the sim so that's where any delay would be.

 

Check Spy and make sure it reports the correct P3D version for its operating mode. The latest beta operating in P3D v3 mode will automatically use SimConnect for all external view eye movements.

 

There are no reported PDK problems reported with this beta as it only uses the v3 PDK for VC views.

 

Stephen

You should re check your camera views Config and make sure the correct button and aircraft have been assigned, hence make sure the view is actually active with your currently selected aircraft.

 

Also check to make sure the views eye point can be controlled within the edit dialog.

 

This could be a confused P3D mode problem. It must recognise P3D v3 mode from the P3D installed folder name. Email me a screen shot of your Config dialog, Spy window, and camera edit dialog and I will take a look.

 

Stephen

 

opusfsi@opussoftware.co.uk

Share this post


Link to post
Share on other sites

I will, ASAP, thanks.

My P3D is installed as "D:\P3D" - as short as that.

I will check as you instructed, but in general everything seems to be good, it was actually working fine before installing the beta, with PDK within the Virtual Cockpit. I double checked: when I un-tick the "Use PDK" option (and reload, off course) it works fine, quick, I suppose this is SimConnect mode. Then when I tick the "Use PDK" option (reload...) it will eventually stop working and bring the view to the default airplane position (PMDG 777 that is).


Best regards,

 

Wanthuyr Filho

 

qpwqa8-6.png

Share this post


Link to post
Share on other sites

The install folder name might be a problem, the software is searching for a v2 or v3 indication. This might be the problem as the software cannot determine what version of P3D you have. Due to the various LM bugs and anomalies the two versions have to be treated differently, some things work in one version but not the other etc..

 

Stephen

 

If SimConnect mode works well for you, you can stick with it. The PDK in v3 is only used for VC view modes anyhow. Weather injection is also different between the two versions also due to v3 coding problems.

 

Stephen

 

The PDK problems would be related to the problems within the LM PDK code for v3 which is faulty and does not work when in non VC view modes. This can cause the PDK to stop working or processing requests completely. Nothing we can do to rectify this as its all down to the P3D code.

 

Stephen

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...