Sign in to follow this  
flying engineer

fsInsider.dll problem again

Recommended Posts

Am back being unable to use MCE due to fsInsider.dll.

 

Identical to topic started 39th Sept 2015 by myself.

 

All was working OK for quite some time using version 2.6.7.3.

 

Then, for some reason, FSX was not able to start up.

 

Renaming fsInsider.dll allows FSX starts up OK.

 

Reviewed all the help suggestions from back in 2015.

 

Never did get a fix and ended up doing a complete reinstall of my entire system to get MCE up and running.

Am not going to do that again and will just give up trying to use MCE if no easy fix is available.

 

I really enjoyed MCE when it was working and the FS++ crew put a lot of effort into helping me right from day one many years ago.

 

Am hoping that someone has found an easy fix for this problem and can post it here.

 

Edwin Brown Osoyoos BC Canada

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Edwin,

I've had this happen a few times, since upgrading to Windows10. It normally occurs after FSX has not closed properly or crashes.

 

I posted a solution I while back, but to save you searching for it.

 

This was Pete Dowson solution for a similar problem with fsuipc.dll

 

Look for similar regedit entries for fsinsider.dll. Just search for "IgnoreFreeLibrary" in the Registry.

 

1) start regedit

2) goto key HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

3) delete the key "C:\\Games\\FSX\\fsx.exe"="$~ RUNASADMIN IgnoreFreeLibrary<FSUIPC4.dll>"

4) if you would like to run FSX as an administrator you need to activate that again as you removed that in step 3

 

It means that freelibrary calls are ignored (calls used to unload a DLL, known as module in FSX). This probably means that one of those calls somehow failed once and the key was added by the MS compatibility 'service' as a service to you...

 

You may get the message again on starting FSX but just say Yes and continue and all should be OK again.

 

 

In your case you will of course have to rename fsinsider.dll (that you changed the name of) back to its original name.

 

Hope the above helps.

 

Stuart

Share this post


Link to post
Share on other sites

Stuart,

Found 2 fsinsider reg entries and deleted them.

Happy to say that I can now start FSX and MCE.

Thank you very much for the help.

Edwin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this