Sign in to follow this  
annber

My GTN750 works flawlessly on fsx. Will the GTN750 work on P3D v3.3 +?

Recommended Posts

Before I take out the wallet, can someone here confirm that it works on P3D 3.3? Flight1 website says:

 

NOTE: These Downloads Are Below Are For Prepar3D 2.2+ and Version 3.0

 

No mention of 3.1, 3.2, or 3.3

 

Bernardo.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It works , there is a small Flight 1 update program that you run and it patches the GTN every time there is a update etc. 

 

Edit : On that note , don't upgrade your sim on day one every time they release an update. Wait a few days until F1 releases the new version file.

Share this post


Link to post
Share on other sites

I have only used GTN 750 in P3d, including v3.3 and it is PERFECT> I simply do not want to fly GA flights without it!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this