Sign in to follow this  
Cargostorm

PMDG 777 and MCE - monitoring of speeds

Recommended Posts

Hi,

 

it is known that unfortunately MCE cannot read the V speeds from the FMC of PMDG's 777. However, even if I tell the FO the V1, VR and V2 speeds, there is no announcement by the FO during take off roll. The speeds appear correctly in the GUI of MCE though. The FO does not even recognize that I am in flight mode, as also the announcement "positive rate of climb" does not sound. The FO is also silent when capturing the localizer or deviate from pre-defined flight path. All switches and autopilot commands work however.

 

Does anybode know why the FO is silent with the 777 even if I tell him the V speeds? This was the workaround for that plane suggested in this forum.

 

This is on Windows 8 64bit, P3D V335, and all apps run as administrator. MCE is the latest version 2674 - but the problem was already there some versions before.

 

Regards,

Chris

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

 

it is known that unfortunately MCE cannot read the V speeds from the FMC of PMDG's 777. However, even if I tell the FO the V1, VR and V2 speeds, there is no announcement by the FO during take off roll. The speeds appear correctly in the GUI of MCE though. The FO does not even recognize that I am in flight mode, as also the announcement "positive rate of climb" does not sound. The FO is also silent when capturing the localizer or deviate from pre-defined flight path. All switches and autopilot commands work however.

 

Does anybode know why the FO is silent with the 777 even if I tell him the V speeds? This was the workaround for that plane suggested in this forum.

 

This is on Windows 8 64bit, P3D V335, and all apps run as administrator. MCE is the latest version 2674 - but the problem was already there some versions before.

 

Regards,

Chris

 

Could be a case of MCE not getting data from the sim, hence the lack of call-outs and even situation awareness.

 

When Windows UAC is enabled, and we don't recommend disabling it unless you prefer to, you MUST.

 

1 - Install MCE to default C:\Program Files (x86)\ folder

 

2 - Set "Prepar3D.exe" to run as administrator.

 

Also, if starting Prepar3D with a launcher app like "FPS_Limiter" or other, the launcher app exe itself must be set to run as administrator.

 

With 777 patched to latest service pack and engines running, go to MCE <Sim> tab and check the engine running status is reported correctly. 

 

Also, report the "mcpmd77X.dll" version number in your \Prepar3D v3\MCE dlls\ folder.

Share this post


Link to post
Share on other sites

Hi Gerald,

 

Thanks for your prompt reply. Your customer service is excellent as ever!

 

I have solved the issue:

 

The version number of "mcpmd77X.dll" in my \Prepar3D v3\MCE dlls\ folder was 1.0.51.

 

I have manually copied the MCE dll files from the backup folder that sits in the MCE installation folder, and found that these files are newer than the ones in the Prepar3D v3\MCE dlls folder.

I can confirm that now with the latest version of mcpmd77X.dll, which is 1.0.53, the call outs in the 777 are correct.

 

My suggestion would be that your MCE installer takes care of these files and that it overwrites the dll files in the \Prepar3D v3\MCE dlls folder when a new version of MCE is installed. Otherwise one has to copy those files manually as it was the case with me.

 

Cheers,
Chris

Share this post


Link to post
Share on other sites

 

 


My suggestion would be that your MCE installer takes care of these files and that it overwrites the dll files in the \Prepar3D v3\MCE dlls folder when a new version of MCE is installed. Otherwise one has to copy those files manually as it was the case with me.

 

It is supposed to do that when you run "InstallMCE". It starts by overwriting fsInsider.dll (Latest is V2.6.7.4. it's important you replace it, as it could affect GSX operation) in \Prepar3D v3\ and all dlls in \MCE dlls\ folder, then proceeds to install MCE outside the simulator folder. Unless it can't read the P3D installation path in registry. Maybe using third party tools which affect that or renamed "Prepar3D.exe to "fsx.exe"???

 

 


Somewhere I have read that you can insert an entry under OPTIONS in the mce.ini if you fly as the FO (something like flyascopilot=1). Unfortunately I cannot find the thread and the entry is not described in the manuals. 

 

Add this option

 

FlyingAsCopilot=1

Share this post


Link to post
Share on other sites

It is supposed to do that when you run "InstallMCE". It starts by overwriting fsInsider.dll (Latest is V2.6.7.4. it's important you replace it, as it could affect GSX operation) in \Prepar3D v3\ and all dlls in \MCE dlls\ folder, then proceeds to install MCE outside the simulator folder. Unless it can't read the P3D installation path in registry. Maybe using third party tools which affect that or renamed "Prepar3D.exe to "fsx.exe"???

 

Thanks a lot Gerald for your answers. It seems that the registry path is correct. FSinsider.DLL is 2.6.7.4.

 

BUT: If you look in the mce.zip download package under "Resources", the version of the respective mcpmd77X.dll is still 1.0.51.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this