Sign in to follow this  
Manny

Saitek Instrument Panel S/W hits on FPS

Recommended Posts

I got the wonderful gauges from  FSXTimes.. so I could have the throttle gauges for my Saitek Instrument panels.

 

I've been using Saitek Instrument Panels on my old machine without any issues... I created some gauges like the Duke D60 Manifold pressure gauge, RP Gauges for the Real Air D60. I used the screenshot of the Real Air panels and made it myself and been using all these years without an issues.

 

But I felt it was easier just purchasing these gauges from FSXTimes instead of spending so much time to do it myself.. I particularly liked the Duke Turbo Engine gauges and got them  yesterday.

 

https://fsxtimes.wordpress.com/2016/06/08/362-duke-turbine-engine-gauges-released/

 

This required I download the latest and greatest Driver and panel s/w from Saittek and everything works fine......

 

Except this time, I noticed a big hit on FPS..almost 30% FPS hit on my new built PC.  My FPS went from 38FPS to 20FPS.... 

 

Any of you using these new s/w and driver from Saitek? Do you have similar issues? 

 

I googled and found similar issues...

 

Another thing is, When I remove the entry from my EXE.XML so I can manually run the Saitek Panel, something keeps inserting the enty back into my EXE.xml

 

 


You could get these gauges from here if you are interested.

 

http://www.fsxtimes.tomandmiu.com/index.php?page=9069593ed57295f7130a7e632faa2468

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I own 9 FIPs (plus Tom's gauges as well) and I can confirm the FPS hit (plus introduction of micro stutters). This was with the Saitek driver on the same machine.

 

Fortunately, I have a second machine (laptop) at hand which runs the SPAD.neXt driver networked, and gone is the FPS hit. I think, the recent version of the Saitek driver can run networked, too. Besides, you can use the Laptop for GPS display, running weather addons (AS) and the like, all taking load off the main machine.

 

If you don't have a second laptop, one thing I would try is playing with HT on and different core settings for the simulator and Saitek driver (DirectOutput) (e.g. taking the Saitek driver off Core 0), but that's a science in itself.

 

BTW, the issue is not with Tom's gauges (at least not for me) but with the driver load on the machine.

 

Kind regards, Michael

Share this post


Link to post
Share on other sites

 

 


Fortunately, I have a second machine (laptop) at hand which runs the SPAD.neXt driver networked

 

Where can I get instructions to do this Mike.. I have a second PC.. Do I have unplug the Saitek gauges and plug it into  the second PC?

Share this post


Link to post
Share on other sites

Yep, of course you obviously have to plug them into the laptop. And if you've got a number of them use a good powered hub they eat a lot of power.

 

Next, you have to install the recent Saitek drivers on the laptop. Now you have to start SaiflightsimX.exe (or similar, I don't have the Saitek drivers installed anymore) by hand, as you can't call it anymore via exe.xml., As far as I remember you have to find a proper point in time during startup of the simulator (I think the point when the simulator goes into graphics mode is okay).

 

Of course this requires the Simconnect connection working between both machines. 

 

There are tools like SimStarter allowing to automate the start, but basically this should do it. Or you use SPAD.neXt which gets rid of all the Saitek stuff altogether and can be started in advance of the simulator,

 

I have all Saitek stuff (Cessna Yoke and friends, Radio Panel and friends and 9 FIPs) connected (via 3 powered hubs) and running via a laptop using SPAD.neXt.

 

Kind regards, Michael

 

Edit: The pdf booklets coming with the FIPs basically describe the networked configuration.

Share this post


Link to post
Share on other sites

I installed Process LAsso and it was a nightmare.. this tool is so buggy.. All I did was installed LAsso and then assigned only 1 process the Saitek process and set affinity to use the last two Cores.

 

But this piece of garbage software was  doing  other things  I did not know.. my mouse cursor would get hijacked and my Sim would simply atrophy and die

 

Whelp! Long story short, I uninstalled this crap Lasso

 

and googled for a very simple solution.

 

I wrote a simple simple .bat file with 3 lines..the first line line is to initiate and start fresh (kill any previous saitek process

The second line is to change directory

and third line to start the saitek process with the appropriate affinity mask.

---------------------------------------------------------------------------

taskkill /IM SaiFlightSimX.exe /F
cd C:\Program Files (x86)\Saitek\ProFlight FSX Plugin 
start /affinity 1D4 SaiFlightSimX.exe
---------------------------------------------------------------------------
 
"1D4" is Hex code to use core 2,3 (one thread from each and both the threads of core 4. And leave core 0 alone.
 
I then created a  link to this bat file in my task bar..so whenever I wanted Saitek loaded, I click on it/.. and I have the affinity set the way I wanted..without any buggy tool or its "buy a license nag every time".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this