Recommended Posts

I am trying to get the hang of P2atc and find it works well with MCE, which I have used for many years, but I can not get a PTT button to work reliably with both programs.

 

I use a Thrustmaster Warthog and I have tried to allocate 3 of the joystick buttons in turn to stop the copilot from listening while I talk to ATC.

P2atc has a menu option for this as does MCE.

 

However it only works sometimes, ie the MCE copilot will ignore a number of commands when the PTT button is pressed, which are then acknowledged by the P2atc contoller, but then the MCE copilot will suddenly start answering to other commands given while the PTT button is pressed. Very frustrating!

 

It could be a joystick/button problem but three of the buttons behave in the same way. 

 

I realise p2atc is not finalised yet, but I wondered if there is any way of reliably making PTT buttons always work as they should?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am trying to get the hang of P2atc and find it works well with MCE, which I have used for many years, but I can not get a PTT button to work reliably with both programs.

 

I use a Thrustmaster Warthog and I have tried to allocate 3 of the joystick buttons in turn to stop the copilot from listening while I talk to ATC.

P2atc has a menu option for this as does MCE.

 

However it only works sometimes, ie the MCE copilot will ignore a number of commands when the PTT button is pressed, which are then acknowledged by the P2atc contoller, but then the MCE copilot will suddenly start answering to other commands given while the PTT button is pressed. Very frustrating!

 

It could be a joystick/button problem but three of the buttons behave in the same way. 

 

I realise p2atc is not finalised yet, but I wondered if there is any way of reliably making PTT buttons always work as they should?

 

What method are you using to assign joystick to MCE?

 

Is it by emulating DELETE key down and up via FSUIPC or the "UseWithVoxATC=1" in [GAMEPAD] section inside "mce.ini"?

 

Here is the preferred method.

 

Delete any keyboard emulation you may have made, 

 

Go to <ATC> tab in mCE UI and assign a PTT button as if itending to use it with Native ATC (use same button assigned under P2ATC)

 

Go to "General" tab in MCE an click <More options..> button.

 

In advanced settings screen, click <View config>

 

The "mce.ini" config file will open-up in Notepad. Ensure

 

[GAMEPAD]

UseWithVoxATC=1

 

Leave the other entries as you found them. Save the file

 

Disable the "Talk to ATC controllers" feature in MCE user interface.

 

Restart MCE.

 

From then on, when you hold joystick button down, MCE will assume you're talking to some other ATC system, and will temporarily suspend all MCE speech reco.

 

Originally the option was there to enable simultaneous use with VoxATC, but in fact it can apply to any third party ATC, including Vatsim

Share this post


Link to post
Share on other sites

Thanks very much Gerald, I thought I had tried what is suggested above but I also found unticking the "use delete key" in the MCE UI box seems to have helped to stop the FO from listening in, as well as the other advice.

I'll give it another go!

Share this post


Link to post
Share on other sites

Nope!

 

Darn FO keeps listening, but not always. Very odd.

 

Maybe a Windows 10, USB issue or something to do with my hardware. I will keep fiddling and maybe find a reliable solution.

 

MCE recognises my speech without problem and everything else seems fine.

Share this post


Link to post
Share on other sites

On further experimentation I have found that if I wait say 20 seconds after giving an instruction and hold the PTT button for about 10 seconds before speaking, then the FO does not hear anything!

If I rush it then the FO and ATC both respond.

 

Must be some buffer or something in the system taking its time to clear, or something...

Share this post


Link to post
Share on other sites

On further experimentation I have found that if I wait say 20 seconds after giving an instruction and hold the PTT button for about 10 seconds before speaking, then the FO does not hear anything!

If I rush it then the FO and ATC both respond.

 

Must be some buffer or something in the system taking its time to clear, or something...

 

Could you please post a screenshot of the <About> tab in MCE user interface? Thanks

Share this post


Link to post
Share on other sites

I took a screen shot but can't attach it to my post, so here is the info contained in it:

 

system info:

 

sound output: speakers (turtle beach PX 11)                         [uSB headset]

sound input:   Microphone (turtle beach PX 11)                     [uSB headset]

processor: Intel core i7 3820 CPU @3.60Ghz

clock frequency: 4499MHz

CPU core count: 04

Installed memory: 16334MB

percentage used: 17%

Free Physical Ram: 1351MB

OS version: Windows 10, 64bit

system ID:22D8CAC5172B519DFEC433

 

MCE ultimate Edition, version 2.6.74

 

Hope it is of some use!

Share this post


Link to post
Share on other sites

Thanks for the info.

 

I was hoping to see a sluggish system with saturated memory. Obviously not the case.

 

I take note system is overclocked to 4.5 GHZ (as detected by MCE "clock frequency 4499MHZ")".

 

While this shouldn't be an issue, just keep in mind, now with speech engine running, the audio device works much harder on both delivering simulator audio and taking speech in continuously.

 

It is important your turtle beach PX 11 is plugged directly to a USB 2 connector on the back of PC, and not the front connectors (which may not deliver enough power to the USB headset built-in audio chip), and definitely not via a USB hub.

 

Joystick doesn't need much bandwidth with regards data. In theory should work fine in a shared USB port scenario.

 

MCE monitors the joystick directly using DirectX. If the assigned PTT button is down, it should see it within 300 ms max.

 

Disabling all commands and enabling those for ATC could take up to half a second, but nothing like 10 seconds.

 

I am just guessing. It's possible because your overclocked gear has been performing well before MCE, you are assuming it will still do.

 

Maybe power supply taking the strain and starving the USB device of the power it needs to run smoothly.

 

The only way to test that, is to revert to stock CPU speed 3.6 GHZ and see if you get the same behaviour.

Share this post


Link to post
Share on other sites

Thank you for such a helpful and constructive reply which makes a lot of sense, of course.

 

This system has been running without problems for a few years so as you say, I am assuming everything it encounters will work without issue, but this may well not be the case.

 

I will try slowing it down to default temporarily, and that will probably cure it  but in the mean time I discovered I had, a long time ago, installed official Thrustmaster drivers for the joystick, which should not be required I suppose in Windows 10, so I uninstalled them.

 

The result is if I press and hold the PTT button and pause for about 4-5 seconds before speaking, then the FO does not hear anything when I speak.

 

I can live with that, though not ideal, it will do, and I will get used to it.

 

Thanks again for your help and suggestions.

Share this post


Link to post
Share on other sites

 

 


I can live with that, though not ideal, it will do, and I will get used to it.

 

You don't have to live with that.

 

We just assumed it was working perfectly because hardly anyone reported it.

 

With hindsight it appears there was some sort of lag. Could be 1 or 2 seconds before all reco is muted. Just not in the 10 seconds time frame you reported.

 

We decided to do something about it. Please try latest release and report back

 

http://www.multicrewxp.com/Downloads.html

Share this post


Link to post
Share on other sites

Thank you very much for looking into this again, I will try the new version and report back.

 

I said "I would live with it " because I believe the issue is probably something to do with my equipment and there is nothing "wrong" with MCE, and I don't want to start reconfiguring my setup when I can put up with a few seconds delay before issuing an instruction. It might all go pearshaped!

 

As ever with my dealings with MCE, your customer service has been exemplary.

Thank you again for that.

 

I will see how It goes with the new release.

Share this post


Link to post
Share on other sites

I have tried the new version and there is now a tiny delay in switching off recog. which seems to coincide with the ATC menu box appearing and then disappearing, when I press the PTT button.

 

I have "autohide the atc window "checked and also "use del key", and "use button 1 " checked, in the menu.

 

I don't remember the ATC box making a momentary appearance before, but maybe I just didn't see it! Can it be prevented from showing up completely? I have "auto open" disabled in the main P3D menu too.

 

Apart from the ATC box issue, which is very minor, this will be perfect for me now, thank  you very much for your efforts, once again.

Share this post


Link to post
Share on other sites

I have tried the new version and there is now a tiny delay in switching off recog. which seems to coincide with the ATC menu box appearing and then disappearing, when I press the PTT button.

 

I have "autohide the atc window "checked and also "use del key", and "use button 1 " checked, in the menu.

 

I don't remember the ATC box making a momentary appearance before, but maybe I just didn't see it! Can it be prevented from showing up completely? I have "auto open" disabled in the main P3D menu too.

 

Apart from the ATC box issue, which is very minor, this will be perfect for me now, thank  you very much for your efforts, once again.

 

That is normal behavior when using MCE with Native FSX/P3D ATC, RC4 or PF3 ATC which are fully supported in MCE.

 

The moment you hit the DEL key or Joystick button, MCE brings up the ATC window in order to refresh it with new content and to give you a hint you're about to talk to ATC it supports.

 

To use MCE with Pilot2ATC, you need to proceed as follows.

 

Keep same joystick button assigned under MCE and PilotToATC.

 

Go to "General" tab and lcik <More options>

 

In "advanced options" panel, click <View config>

 

The "mce.ini" config file will open in Notepad.

 

Go to [GAMEPAD] section and change "UseWithVoxATC=0" to "UseWithVoxATC=1". Don't forget to save.

 

Now, since you aren't using any of the directly supportd ATC systems (see above), disable the "Talk to ATC controllers" feature in MCE user interface and re-start it.

 

From then on, MCE won't do anything with Pilot2ATC other than monitor assigned PTT, and when seen as pressed, will immediately disable all MCE speech recognition, until you release it. There should be no interference from FO trying to guess what you spoke to Pilot2ATC. At least, that's the intent.

 

I know "UseWithVoxATC=1" should really be "UseWithOtherATC=1" (it applies to Vatsim as well). And will probably end up like that. Because we introduced the option initially to support concurrent use with VoxATC it was named as such. And didn't want to break it, as some users would have it enabled.

Share this post


Link to post
Share on other sites

It has been a little while since I last posted about this, but interestingly I have found that if I use MCE version 2678 then I do not have any problem with my copilot listening to my ATC instructions when I press the PTT button, but if I update to the latest versions then that problem resurfaces.

 

There must be something, missing or added to 2678 that fixes the issue for me, that the later versions lack, or have, if that makes sense!

 

I will contnue to use 2678 as it works for me, and will try the new updates as they are issued reverting to the old one if the problem reappears.

 

I tried un-overclocking, but unfortunately it didn't help in this case.

 

This is just for your information, everything is fine for me using 2678.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now