Sign in to follow this  
FredricG

Framerate severely drops with sound on

Recommended Posts

This just happened now - I was taking off from runway 1R at McCarran airport in the PMDG 737 when my sound in FSX just quit on me. When I attempted to turn it back on, no sound came out and my framerate dropped to 2fps. I have no idea what's wrong. Could it be a driver thing?

Some help would be appreciated.

 

Thanks!

 

FredricG

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The sound hardware is using the main processor CPU as it's processor so the visual rendering and the audio rendering are interfering with each other.  Many motherboards with built-on sound controllers do this to reduce cost and complexity.

 

See this article about 2/3's the way down.  https://uchisworld.wordpress.com/tag/system/

 

An inexpensive add-on sound card will not only sound better but you can completely disable the built-in and put all that processor usage toward the graphics.

Share this post


Link to post
Share on other sites

The sound hardware is using the main processor CPU as it's processor so the visual rendering and the audio rendering are interfering with each other.  Many motherboards with built-on sound controllers do this to reduce cost and complexity.

 

See this article about 2/3's the way down.  https://uchisworld.wordpress.com/tag/system/

 

An inexpensive add-on sound card will not only sound better but you can completely disable the built-in and put all that processor usage toward the graphics.

I think I do have a sound card... My default sound defice is "Realtek High Definition Audio". My computer is an MSI GP70 2PE Leopard gaming laptop. I think it's something to do with my drivers.

Share this post


Link to post
Share on other sites

Pretty easy to tell if you have this problem. Open FSX-SE in a windowed view and make it cover up about half the screen. Open task manager and position it on the other half of the screen. Click into the FSX windows and turn the sound on and off while you watch task manager. If your processor utilization goes up and down with sound on and off, then this is what is happening.

 

Very few laptops have a separate processor for sound, they almost all used the shared processor configuration.

Share this post


Link to post
Share on other sites

Realtek High Definition Audio is built into your laptop's motherboard (eg. onboard sound, not a sound card).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this