Sign in to follow this  
spesimen

external views stopped working with 1.59

Recommended Posts

hi, i get an error message about chaseplane not being able to change the camera or something and it points to a thread about fslabs airbus and some other aircraft.

 

my external view is stuck inside the aircraft and switching presets doesn't seem to do anything.

 

it looks like according to that post there is some hotkey i can edit or remove, but i think something is amiss as i did not need to edit anything for this stuff to work before. it was working great yesterday! the planes i'm seeing the problem with are the jahn c-47 and the pmdg 737.

 

UPDATE:

after looking at the aircraft.cfg it seems there are hotkey=4 entries for each of those planes, in the camera entries that were added by ezdok. i commented them out as suggested in the other thread, but this did not solve the issue.

 

on the c-47 hitting my external hotkey now changes the view to FO RIGHT ENGINE.

 

on the 737 it says my view is 'onboard (chaseplane)' but moves the camera sort of above the aircraft, and it is a skeletal model with only the VC and wings appearing.

 

cheers

-andy crosby

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

on the 737 it says my view is 'onboard (chaseplane)' but moves the camera sort of above the aircraft, and it is a skeletal model with only the VC and wings appearing.

 

I have the same issue. Since update 0.1.59 ChasePlane isn't working at all.

Share this post


Link to post
Share on other sites

still no luck with this bug and 1.61

it seems like still confused somehow about switching the camera.

 

here you can see before commenting out the hotkey=4 line it switches to the ezdok cam for some reason. this entry did not cause any problems for me until yesterday. i don't know if it is a clue but i thought it was odd that none of the camera entries had a checkmark beside them (in any of the categories).

GTeNfFO.jpg

 

and then here, if you comment out the hotkey line, it stays on the chaseplane internal view cam instead. if i manually select the outside chaseplan cam, it works ok, but will reset to the wrong one if i switch internal/external again.

rGdux3C.jpg

 

cheers

-andy crosby

Share this post


Link to post
Share on other sites

ChasePlane should look in the cameras.cfg file to remove any pre-existing EzDok configuration. Not sure how your setup manages to skip ChasePlane's detection system.

 

Can you send me a copy of your cameras.cfg file? (From dropbox or something)

 

Thanks

Keven

Share this post


Link to post
Share on other sites

is it this one from the root of my fsx directory?

 

https://drive.google.com/open?id=0B0GionmeXlyyX1BhekJabTNwOTg

 

according to explorer it does not appear to have been changed since mid-july.

 

ezdok adds a camera entry to each aircraft's aircraft.cfg maybe that is tripping it up somehow? i tried removing it but it had the same effect as just commenting out the hotkey line.

 

good luck!

 

cheers

-andy crosby

Share this post


Link to post
Share on other sites

Sorry, I wasn't clear enough. The cameras.cfg file i'm looking for is located in %appdata%\Microsoft\FSX

 

Thanks

Keven

Share this post


Link to post
Share on other sites

i think this is the right filethen:

https://drive.google.com/open?id=0B0GionmeXlyyYkxLZFk0NmtnaVE

 

anyway i'm still seeing this odd behavior with 1.66 also, it doesn't appear to have made a difference.

 

i tried removing the ezdok entry from both the cameras.cfg and from the aircraft.cfg ... it solve the issue of going to the ezdok cam, but still stayed with the cockpit/interior cam instead of switching to the outside one (showing only the vc and wings.)

 

i also tried renumbering the CP entries after removing those, to 201,202,203, didn't seem to make a difference either.

 

it seems like it correctly numbered them 203-205 before, maybe it's not picking the right one anymore because 201 and 202 are taken?

 

in the other thread about this you mentioned the possibility of an ezdok install perhaps being related but i didn't reinstall ezdok at all... i thought CP had simply removed the ezdok process from automatically starting. sometime last week i did start ezdok manually for a flight or two on one of the days where CP was having shenanigans, perhaps it re-edited some files?? this was still several days before it stopped working and i'm pretty sure it worked in the interim period. also i'm pretty sure i ahve that 202 entry in almost all of my planes since whenever i last ran the indexer for it, is the idea that all of those have to be edited or removed now?

 

good luck!

cheers

-andy crosby

Share this post


Link to post
Share on other sites

Hey Andy,

 

Can you contact us through the Alpha email?

I would like to do a Teamviewer session with you to find the root of the issue once and for all!

 

Best Regards,

Keven

Share this post


Link to post
Share on other sites

Hey Andy,

 

Can you contact us through the Alpha email?

I would like to do a Teamviewer session with you to find the root of the issue once and for all!

 

 

sure thing.

 

that may not be necessary as i discovered a solution though!

 

the issue appears to be related to the other change made to my cameras.cfg ..

 

the [CameraDefinition.002] has been entirely commented out. this is the one that says Title=Virtual Cockpit

 

i think CP must have done this as i haven't edited that file ever lol..

 

when i remove the comment slashes for that entire entry, everything works fine again! does this make any sense?? it works lol!!

 

good luck

 

cheers,

-andy crosby

Share this post


Link to post
Share on other sites

The VC view has been disabled as it is replaced by the On-Board one we inserted. I used your CFG file on my system and I cannot reproduce the issue.

 

I was able to reproduce a different reported issue related to views freezing and being unusable. I updated v0.1.67, let me know if that fixed your issue as well.

Share this post


Link to post
Share on other sites

unfortunately still not working in 1.67.

 

with 1.67 re-enabling the camera.definition002 does not fix it anymore either.

 

edit: confused about which file i tried. it seems to correctly avoid the ezdok cam now (i think because now it is modifying the entry in aircraft.cfg ...commenthing out the hotkey gave same behavior before).. it still stays stuck in chaseplane onboard view when switching to outside view. if i manually pick chaseplane outside view it seems ok. switching back works fine also. but then to switch again it has same issue.

 

guess you might have to look at it on my system after all! i'll be in touch on email

 

cheers

-andy crosby

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this