Sign in to follow this  
Pete Dowson

P3D Menu entry "10" not usable except by Mouse?

Recommended Posts

I can't believe this! The SimConnect menu bug which I'm sure was reported months ago, is still there -- the one where the SimConnect menu's 10th item is labelled 10, not 0, and in fact does not accept key 0!

 

There is no key "10"!  I'm very surprised that the L-M chaps don't realise this!  And many applications use 0 to clear the menu -- it may even be the default use for all I know. But this bug means (along with one I've recently discovered, the hard way, where the latest version of P3D crashes immediately you try to use an assign SimConnect Menu N event) that there is no way at all to properly operate menus by keypress -- and therefore no way for joystick buttons!

 

This currently rules out using P3D for my cockpit. No way is a mouse invading it's interior! :-(

 

Doesn't anyone else here have these problems?

 

Pete

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I had noticed this in ref to "0"

 

http://www.prepar3d.com/SDKv3/LearningCenter/what_is_new/new_v33.html

 

Prepar3D v3.3

Release Notes

Prepar3D Client

Fixes and Improvements

 

 

Fixed bug where pressing '0' would not activate the last option in the ATC menu.

 

Yes, I thought they'd fixed it and it did work. It seems to have changed recently.. I'm on 3.4.14 at present. no wy could I get it to work here.

 

Pete

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this