Sign in to follow this  
flyguycaa

View panning suddenly stopped working

Recommended Posts

Help.  Started FSX (boxed version) today and the panning doesn't work, either in the VC or in outside view.  I have it assigned to the Hat Switch on my HOTAS Warthog throttle.  The hat switch works fine, and everything is normal in P3D.  I NO NOT use Ezdok or any other camera software.

 

I have attempted clearing the assignment, restarting the sim and reassigning it without luck.  Also, FWIW, I have never used "mouse view", so I'm not sure how it works, but when I hit Shift-O I get a cross on the screen, but moving the mouse does NOT move the view around, with or without mouse buttons pressed.

 

I'm thinking that I mistakenly hit a key or key combo that locked panning, but I've been searching on Google for about 4 hours and haven't found anything.

 

If anyone has any ideas I would be very grateful :)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

When using the mouse view, are you holding down the spacebar when moving the mouse?

Share this post


Link to post
Share on other sites

Yes, and was not working.  In fact, no view movement was working at all, inside or outside, either through keyboard, hat stitch, or mouse.  ALL my controls are set up through FSUPIC, except the View (Pan) control, because FSUPIC doesn't seem to do that as smoothly.  Turns out that I had somehow hit CTRL-K, which apparently disables all controls directly input on FSX, but not those in FSUPIC.  Once I hit it again everything returned to normal.

 

Thanks for the response.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this