Sign in to follow this  
pkofman

x52 joystick system and xp-11

Recommended Posts

Has anyone had any luck calibrating an x52 joystick system with x p 11 

I cannot get the views to stick to the hat switches and rarely to the assignment work correctly

Moreover I seem to have to reassign the control assignments at each start up

I looked in the x52 profile section of saitek but there is no profile for xp11 at this time

Thoughts. 

Peter

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

My X52 is working perfectly in X-Plane 11. 

 

But I'm not using Saitek's profile software; just X-Plane's controller settings,

Share this post


Link to post
Share on other sites

My X52 is working perfectly in X-Plane 11. 

 

But I'm not using Saitek's profile software; just X-Plane's controller settings,

 

That's fantastic.. I'm having issues with button reassignment and in particular the second hat switch in my case I use to move up down left and right. The assignments in the x52 diagram and button choices are all messed up and not correct.. What I mean by that is that the view control direction does not match the direction. I also have to reset my  axis on the controller at every start up. I must be doing something wrong. Glad you  can get it to work. BTW I'm using xp11 latest beta , w10x64  . I am not using the profiler but I did download it.

I wonder if you can provide and further advice. I am probably making a silly mistake  Peter

Share this post


Link to post
Share on other sites

That's fantastic.. I'm having issues with button reassignment and in particular the second hat switch in my case I use to move up down left and right. The assignments in the x52 diagram and button choices are all messed up and not correct.. What I mean by that is that the view control direction does not match the direction. I also have to reset my  axis on the controller at every start up. I must be doing something wrong. Glad you  can get it to work. BTW I'm using xp11 latest beta , w10x64  . I am not using the profiler but I did download it.

I wonder if you can provide and further advice. I am probably making a silly mistake  Peter

This is how I have mine assigned:

Button 16: Move view up

Button 17: Move view right

Button 18: Move view down

Button 19: Move view left

 

You do have Device set as Saitek X52; right?

And you have run Calibrate?

 

Also I have my Saitek profile software disabled, and have selected "Saitek X52 Flight Controller" as my Preferred device under Windows 10 Control panel.

Share this post


Link to post
Share on other sites

" . . . I am not using the profiler but I did download it."

 

The fact that you've downloaded Saitek's profiler and may have installed it, I'm wondering if the profiler activates automatically which would be the source of the issue. If so, you may want to try uninstalling it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this