Sign in to follow this  
thecanarian

It was all going so well

Recommended Posts

Hi,

After many months/years of running ASN/ASN16 on a client PC with FSX:SE on the server; today it ain't connecting.

So far I've :

  • un-installed/re-installed ASN16
  • verified the cache on Steam
  • run the ASConnect2016_FSX.exe a couple of times
  • Shut and powered down a few times ....

and still ASN16 fails to connect. From looking at the log files simconnect appears to be loaded and running on the client (ASN16) PC but the server PC ain't communicating. Has anybody got any ideas :

  • Why it may have failed after all these months
  • What individual components to check to ensure they are operating as they should
  • Anything else that may help

Thanks in anticipation

Peter

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had the same happen to me a while back. I ended up being a corrupted SimConnect.xml file on the host computer.

I copy a sample from the SDK folder and it worked.

Share this post


Link to post
Share on other sites

Thanks for the info.

The IP address on my (FSX) server is anumber....66 whereas the .xml file has it as anumber.....87, and the client PC is anumber....194. It looks like an IP address may have been re-issued (?). Which one does the .xml file need client or server ?

Share this post


Link to post
Share on other sites

Well I've changed the IP address of the server in SimConnect.xml to the current one ending in 66, but still no joy. It seems that SimConnect is not initiating when FSX:SE loads. Has anybody got any ideas what I try next ?

Share this post


Link to post
Share on other sites

There's several regular things can stop your simconnect running across your network, for example a DHCP server on your router has reissued ip addresses, or the port you specified has subsequently become blocked.

 

On your server you should have the file "Simconnect.xml" in your User folder:

..\Users\[you]\AppData\Roaming\Microsoft\FSX on a single installed FSX:SE system

or

..\Users\[you]\AppData\Roaming\Microsoft\FSX-SE on a dual FSX/FSX:SE installed system

 

the contents should look like this but you would substitute your server ip in the <address> line. The port should be any port over 1024 except 8080, I've used 1025:

 

<SimBase.Document Type="SimConnect" version="1,0">
   <Descr>SimConnect</Descr>
   <Filename>SimConnect.xml</Filename>

   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>Global</Scope>
      <MaxClients>64</MaxClients>
      <Address>192.168.1.124</Address> <- insert your server ip
      <Port>1025</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>

   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>Auto</Protocol>
      <Scope>Local</Scope>
   </SimConnect.Comm>

</SimBase.Document>

on your client PC in C:\Users\[you]\Documents a file called "Simconnect.cfg", using the same ip and port:

 

[SimConnect]
Protocol=IPv4
Address=192.168.1.124 <- insert your server ip
Port=1025
MaxReceiveSize=4096
DisableNagle=0

If you get that going you can change the address to \\MyPCname (your PC name) to avoid going wrong if the DHCP service alters the ip, the DNS service maps your PC name to the ip address given by the DHCP service.

Share this post


Link to post
Share on other sites

A HUGE thanks Steve. The file I didn't update was the SimConnect.cfg with the new IP Address in my Documents on the client PC....... I just knew there should be something on the client PC but I couldn't track it down.

Delving into (on server PC)  AdminTools/System Information/Components/Network/Adapter .... it seems the Microsoft Kernel Debug Network Adapter reset itself yesterday morning, and thus acquired another IP address. Why it should do that I've no idea .... but my wife was using the PC at that time ......

 

Thanks again Steve

Peter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this