Sign in to follow this  
GreyGoose

G1000 problem with hypergauge.dll

Recommended Posts

I'm having a problem with the G1000 and could use some guidance.
 
I'm running FSX-SE on a Windows 10, 64-bit, PC (i5, 3.2Ghz, 8 Gb RAM).  Initially, FSUIPC version 4.959 was installed.  No other add-ons.   The PC is brand new and all software is up to date.
 
I purchased the G1000 yesterday. The installation was normal and my first flight in the C172 (non-AFCS panel) seemed OK - at first.   I was familiarizing myself with the various functions like VOR tracking with the autopilot.  However, when I entered "activate" for the GPS to fly to the nearest airport, the screen froze while the sound continued.   Nothing happened thereafter and I had to exit the program with the Task Manager.    When I restarted FSX I got this error message.
 
"Flight Simulator has detected a problem with a third-party software program (add-on)
  Name: HyperGauge Avionics Accelerator for Microsoft Flight Simulator
  Version: 1.1.0
  Company: Stasi Poulos and Ed Wilson
  File: C:\Program Files (x86\Steam\st...\HyperGauge.dll
 
Do you want to run this software (not recommended)?"
 
 
I tried removing FSUIPC and re-starting FSX but still got the same error message.   I tried uninstalling the G1000 and re-installing it.   Same thing.  The only way I can get FSX to run normally is to remove the hypergauge.dll file from the Modules folder.  When I do that, FSX runs OK but, of course, the Mindstar G1000 aircraft are not usable - if I try to load one, FSX hangs up.
 
I'm not sure what to try next.  Any suggestions would be much appreciated.  What I saw of the G1000 before the crash looked really good.
 
Dave Steinmeyer
 

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Using RegEdit.exe do the following:

 

- Locate the entry "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers"

- Find the value that contains "fsx.exe".

- See if it has an entry for IgnoreFreeLibrary <HyperGauge.dll> in it. If so... delete the value.

Share this post


Link to post

Thanks Ed for the quick reply.  I'll look at that and let you know what I find.

Dave

Share this post


Link to post
OK, I found and deleted that value.   I then put HyperGauge.dll back into the Modules folder and ran FSX.  Got the same error message.  

 

The "IgnoreFreeLibrary..." entry has not reappeared though.

 

Dave

Share this post


Link to post

Did you tell it to RUN the DLL??

Share this post


Link to post

I didn't.  I just ran FSX.  How do I tell it to run the DLL?


Sorry, I was a little slow there.  You meant from the error screen.  

 

I did just tell it to run the dll and now it seems to load again correctly.  I'll do some flight testing and see what happens.  

 

Thanks.

 

Dave

Share this post


Link to post
 

 

 

I'm a happy camper.  The error message doesn't appear when I run FSX now.  Several flights to try out various features and no crashes.

 

I noticed that on the non-AFCS C172 the autopilot ALT function started out OK with the altitude adjustment increment being the usual 100 ft.  Sometime during the flight, this changed so that the increment became 1000 ft.   Operator malfunction???

 

But, since the AFCS version works great, I'll stick with that.  

 

Thanks for your help Ed.  This is an impressive add-on.

 

Dave

Share this post


Link to post

I thought I'd follow up with some more information after additional testing.

 

Today I re-installed FSUIPC version 4.959 (and modified the FSUIPC.ini file as recommended).   I was then able to re-create my original problem.  Loading a GPS route locked up the screen and crashed the program.

 

 I then removed the FSUIPC files from the FSX Modules folder and all returned to normal.    Not being able to use FSUIPC with the G1000 is only a minor inconvenience and it's good to have a work-around solution.

 

Dave

Share this post


Link to post

This is a known issue with FSUIPC and Prepar3D.  L-M has released an update for the current v3 Prepar3D that should address it, but obviously that doesn't fix FSX, right? LOL

 

For Prepar3D there are two settings you can add to your FSUIPC.INI file to address this issue, they work with FSUIPC v4.958d or newer:

 

ProvideAIdata= Yes

ProvideAIairports= No 

 

You might give that a try and see how it goes.

Share this post


Link to post

I did make that change to my FSUIPC.INI file but it didn't help FSX.  

 

After some experimentation, I found that it works best to leave most of the installed FSUIPC files in the Modules folder all the time  - as long as I remove the FSUIPC.DLL file before I run one of the G1000 aircraft.   Then, when I want to run a non-G1000 aircraft, I just place the FSUIPC.DLL file back in that folder and all my FSUIPC settings are back in place.    I've been keeping the .DLL file on my desktop to remind me that it's not installed and it's simple to just drag and drop it into the Modules folder when needed.

 

Dave

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this