Sign in to follow this  
Demious

P3D crashes on start-up

Recommended Posts

This morning everything was fine, I made some adjustments for the new PMDG 747 and I've been able to start up P3D multiple times after that. But from one moment to the next, the P3D splash screen came up and disappeared and P3D doesnt come back up.

At first I got the error message "simconnect does not answer more than 50 seconds etc", from which I found it has something to with EZDok. So I tried several ways to fix it, that I found on the EZDok and P3D forums, but nothing worked.

So I just removed EZDok from my computer. I even checked my computer if anything EZDok-related might have been left, but every folder has been removed.

Now if I start up P3D, the splash screen still disappears and P3D doesnt come back up, but I also dont get the error message from earlier.

If I check the processes list in taskmanager, I can see there's a P3D running, but that's only visible in the process list, nowhere else is any indication P3D is running.

 

So I tried to repair P3D, but no changes. I deleted the Prepar3d.cfg and had P3D create a new one, but no luck. Then I uninstalled P3D client (3.4.18.19475) and installed the newest version (3.4.22.19868), but also no changes.

 

Anyone any ideas on what might be wrong and how I can fix it?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I had this exact same problem. For me it was an issue with the EXE.xml file that is located in C:\Users\[uSER]\AppData\Roaming\Lockheed Martin\Prepar3D v3. I had to change the entry under "as_btstrp_config_manager" from "<Disabled>False</Disabled>" to "<Disabled>True</Disabled>." This deactivated the module that was not loading properly and preventing P3D from running. In my case I believe it was related to AS16, but I think any module could potentially cause this issue.

 

I have heard that the DLL.xml file can also be the source of this issue. There are also two places where either your EXE.xml and DLL.xml files can be located. One is the folder I indicated above and the other is in C:\ProgramData\Lockheed Martin\Prepar3D v3. 

 

You can try disabling modules one by one or you can delete these files and P3D will rebuild them. In the latter case you will lose any modules you have installed like FSUIPC but you can always reinstall it.

 

Always backup the files before deleting/rebuilding!

 

 

Share this post


Link to post

I had the same and disabled FSUIPC in dll.xml 

AS16 has already been updated for the newest P3D 3.4 version.

 

Peter

Share this post


Link to post

Also you might already know this but you'll need to have "Show Hidden Files and Folders" enabled to access the locations of the EXE and DLL .xml files. I can't remember the exact steps but it's an easy Google search away.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this