Sign in to follow this  
Bill Alderson

Trainer Question

Recommended Posts

Hi,

 

Question: I can't seem to load the Garmin Trainer for X-Plane because the setup program keeps telling me that another Trainer Lite already exists and that I would need to remove it.  Do I even need to update the Trainer software? 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It would be easier to help you find the answer if you were more specific. Can you please let me know what Trainer version you have currently installed? If unsure, or to cross check, please go to where the trainer is installed (typically "C:\Program Files (x86)\Garmin\GTN Trainer\GTN\sys\sim") and right click "GTN Simulator.exe" and select properties. In 'details' tab, what is the version number displayed?

Share this post


Link to post
Share on other sites

It would be easier to help you find the answer if you were more specific. Can you please let me know what Trainer version you have currently installed? If unsure, or to cross check, please go to where the trainer is installed (typically "C:\Program Files (x86)\Garmin\GTN Trainer\GTN\sys\sim") and right click "GTN Simulator.exe" and select properties. In 'details' tab, what is the version number displayed?

 

Hello again Jean-Luc.  It's the Garmin Trainer Lite, version 5.13.0.1

 

Thanks for your time.

Share this post


Link to post
Share on other sites

That explains it. The latest RXP GTN 750/650 Touch dropped support for older trainers so as to maintain low resources and performances. In effect, there is no need to support a trainer from 2015 where 99.99% of our customers would fly with the latest, the new features and the latest database. Well, we might have been wrong in dropping support for the older trainers too, however, we've never supported trainer 5.13 but only 6.1.1, 6.1 and 5.0.0.1.

 

Nevertheless, to solve you problem, you must first assess which trainer is compatible with the other product your are using, and I guess it is the latest 6.21 is supported. Once validated, problem solved: just install the latest version of all your GTN products.

 

Otherwise, you'd need to keep 2 copies of 2 different trainers, and for this, we can't tell if the other product you are referring to offers support for this, but we do as found in our User's Manual chapter about this.

Share this post


Link to post
Share on other sites

Thanks Jean-Luc, your first suggestion worked for me.  As a matter of fact the GPS seems to work just fine; no rheostat problems either.  :smile:

 

Thanks again for everything....

Share this post


Link to post
Share on other sites

I decided to fly around in Europe today. But it seems like the GTN 750 trainer database does not contain any European airports. (England, Germany, Denmark, Sweden) is the countries i tried. I have the newest version of the Garmin Trainer 6.21 and GTN 750 for XP. - 

 

I should add that the safe taxi map work fine, but when plan a flight, i get No Matches Found for European airports.

 

Any ideas, or is it just me... :)

 

Thanks in advance.

Share this post


Link to post
Share on other sites

 

 


i get No Matches Found for European airports.

 

Have you made sure you have configured your GTN with 'worldwide' database instead of 'Americas'?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this