Edward Law

VRInsight FCU Combo and LINDA

Recommended Posts

Hi All,

I am new to LINDA and VRinsight FCU Combo. 

Have installed the latest FSUIPC, LINDA and Module for Aerosoft. 

However, when  I run LINDA and select Aerosoft A320, the program reported USER module creation error and termiunated.

Linda2.log read:

 

[MAIN]  LINDA Version Ver 2.8.9 (446) initialising (1702111406) ...
[MAIN]  Can start ...
[MAIN]  Opening Main form
[MAIN]  LINDA Ver 2.8.9 (446) GUI starting...
[MAIN]  Fonts added
[MAIN]  News added
[MAIN]  HID OnArrival 29E4FF0=046D/C52B
[MAIN]  HID OnArrival 29E4F30=046D/C52B
[MAIN]  HID OnArrival 29E5230=046D/C52B
[MAIN]  HID OnArrival 29E52F0=044F/0404
[MAIN]  HID OnArrival 29E53B0=046D/C52B
[MAIN]  HID OnArrival 29E5470=046D/C52B
[MAIN]  HID OnArrival 29E5530=046D/C52B
[MAIN]  HID OnArrival 29E56B0=1B1C/0C04
[MAIN]  HID OnArrival 29E5830=046D/C52B
[MAIN]  HID OnArrival 29E5770=046D/C52B
[MAIN]  HID OnArrival 29E59B0=06A3/0763
[MAIN]  HID OnArrival 29E5B30=1FD1/03EA
[MAIN]  HID OnArrival 29E5A70=046D/C52B
[MAIN]  HID OnArrival 29E5D70=1FD1/03EA
[MAIN]  HID OnArrival 29E5BF0=046D/C52B
[MAIN]  HID OnArrival 29E5EF0=044F/0402
[MAIN]  HID OnArrival 29E5FB0=046D/C52B
[MAIN]  HID OnArrival 29E6070=046D/C52B
[MAIN]  HID OnArrival 29E6130=046D/C52B
[MAIN]  HID OnArrival 29E61F0=046D/C52B
[MAIN]  HID OnArrival 29E62B0=046D/C52B
[MAIN]  HID OnArrival 29E6370=046D/C52B
[MAIN]  HID OnDeviceChange
[MAIN]  >>>HID IsJoystick test = 29E4FF0=046D/C52B = 1
[MAIN]  >>>HID IsJoystick test = 29E4F30=046D/C52B = 2
[MAIN]  >>>HID IsJoystick test = 29E5230=046D/C52B = Keyboard
[MAIN]  >>>HID IsJoystick test = 29E52F0=044F/0404 = Joystick
[MAIN]  >>>HID IsJoystick test = 29E53B0=046D/C52B = 4
[MAIN]  >>>HID IsJoystick test = 29E5470=046D/C52B = Mouse
[MAIN]  >>>HID IsJoystick test = 29E5530=046D/C52B = 1
[MAIN]  >>>HID IsJoystick test = 29E56B0=1B1C/0C04 = 1
[MAIN]  >>>HID IsJoystick test = 29E5830=046D/C52B = Keyboard
[MAIN]  >>>HID IsJoystick test = 29E5770=046D/C52B = System Control
[MAIN]  >>>HID IsJoystick test = 29E59B0=06A3/0763 = Joystick
[MAIN]  >>>HID IsJoystick test = 29E5B30=1FD1/03EA = Undefined
[MAIN]  >>>HID IsJoystick test = 29E5A70=046D/C52B = 88
[MAIN]  >>>HID IsJoystick test = 29E5D70=1FD1/03EA = Undefined
[MAIN]  >>>HID IsJoystick test = 29E5BF0=046D/C52B = Mouse
[MAIN]  >>>HID IsJoystick test = 29E5EF0=044F/0402 = Joystick
[MAIN]  >>>HID IsJoystick test = 29E5FB0=046D/C52B = 1
[MAIN]  >>>HID IsJoystick test = 29E6070=046D/C52B = 1
[MAIN]  >>>HID IsJoystick test = 29E6130=046D/C52B = System Control
[MAIN]  >>>HID IsJoystick test = 29E61F0=046D/C52B = 2
[MAIN]  >>>HID IsJoystick test = 29E62B0=046D/C52B = 88
[MAIN]  >>>HID IsJoystick test = 29E6370=046D/C52B = 4
[MAIN]  >>>hidConfigDftLoad - FSX Default config-hid.lua file not found
[MAIN]  >>>hidConfigReload unsuccessful
[MAIN]  >>>FSXSYNC off and flag=0
[MAIN]  >>>ConfigSysSave() completed
[MAIN]  No Ident.lua file found for aircraft * FSX Default
[MAIN]  Aircraft Selector initialized
[MAIN]  >>>FSX_SYNC unset
[MAIN]  >>>ConfigSysLoad() completed
[MAIN]  >>>FSX_SYNC unset
[MAIN]  >>>ConfigSysLoad() completed
[MAIN]  >>>FSX_SYNC unset
[MAIN]  >>>ConfigSysLoad() completed
[MAIN]  >>>FSX_SYNC unset
[MAIN]  >>>ConfigSysLoad() completed
[MAIN]  >>>FSX_SYNC unset
[MAIN]  >>>ConfigSysLoad() completed
[MAIN]  >>>FSX_SYNC unset
[MAIN]  >>>ConfigSysLoad() completed
[MAIN]  >>>FSX_SYNC unset
[MAIN]  >>>ConfigSysLoad() completed
[MAIN]  >>>hidConfigDftLoad - FSX Default config-hid.lua file not found
[MAIN]  >>>hidConfigReload unsuccessful
[MAIN]  >>>hidConfigDftLoad - FSX Default config-hid.lua file not found
[MAIN]  >>>hidConfigLoad() complete
[MAIN]  Main Timer started
[MAIN]  Opening Viewer form
[MAIN]  Opening Input form
[MAIN]  Opening Macros form
[MAIN]  Opening FSX Controls form
[MAIN]  Opening New Module form
[MAIN]  Opening Editor form
[MAIN]  All Forms opened successfully
[MAIN]  Opening Console form
[MAIN]  HIDSwitchDevice 1
[MAIN]  hidConfigCheck - config-hid.lua file not found (D:\Lockheed Martin\Prepar3d V3\Modules\linda-cfg\aircrafts\Aerosoft Airbus\config-hid.lua)
[ERROR] Fatal Error. LINDA exiting...
[MAIN]  Fatal Error. LINDA exiting...
[MAIN]  Terminating Application
[MAIN]  LINDA Terminated

 

Any help is much appreciated.

 

Edward

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Edward

 

Welcome to the LINDA community. The appears to be an issue creating 2 key files called config-mcp2.lua. This manual procedure should get you working.

 

Open folder /modules/linda-cfg/aircrafts/fsx default.

Make a copy of file config-mcp2a.default and rename it config-mcp2a.lua.

Do the same in folder /modules/linda-cfg/aircrafts/aerosoft airbus.

Restart FSX and LINDA.

 

Enjoy!

Share this post


Link to post
Share on other sites

Hi Scot,

Thanks for your help.

However, there is no joy.

There is no config-mcp2a.default in the /modules/linda-cfg/aircrafts/fsx default and the /modules/linda-cfg/aircrafts/aerosoft airbus

The log file still making the same problems.

 

Thanks.

Edward

Share this post


Link to post
Share on other sites

Hi Edward

 

There was an extension naming issue with the Aerosoft Airbus module. Please download and install Aerosoft Airbus 4.4 v3.

 

Also as you report that the fsx default is also missing the .default files, I recommend you download and install LINDA 2.8.9 again.

 

If the config-mcp2a.lua files are no correctly generated, then locate and rename the config-mcp2a.default to .lua procedure above.

Share this post


Link to post
Share on other sites

Thanks Scot. 

It works now after installing the V3 and 2.8.9. 

However, I've one more issue. How could i remove the FCU combo module? It runs when I run the aircraft. 

Thanks and regards,

Edward

Share this post


Link to post
Share on other sites

I am pleased you have got it working. I am not sure what you would be trying to do by removing the FCU combo module. Ate you referring to the hardware panel or the code module?

 

The VRINSIGHT panel handling is hard coded into the LINDA.EXE.

Share this post


Link to post
Share on other sites

Hi all,

I just bought VR Insight FCU-Combo/Airbus type but it will not working.

In the Linda Settings, the VRInsight MCP Combo is enables, the COM port is assigned and FSUIPC Setup is done, therefore, everything is ok. But I have no Display on the MCP Combo, it only Shows "FCU-Combo/Airbus VRinsight, Flight" - "Type v1.00 Dream Supplier!" - "Instrument Radio via VRiSim". And of course, no button or  Rotary knob is working,

I read some Posts whose having the same Problem and I followed the advices to solve the Problem, but these are not working for my FCU Combo.

I followed the instruction given by the Manual of the VRinsight, so I installed all the necessary Software.

I start FSX, run VRiSim and the program starts to search for VR Hardware and that's it. After half an hour of searching, I stopped the VRiSim.

So I ask the community for help, please could someone Support me?

Erwin Schellnegger

Share this post


Link to post
Share on other sites

Hi ScotFlieger,

thank you for the reply. I read this in one post that I should not run VRSim and Linda together. But since my first post, I tried a lot of things to get the system running and I realized the following.

If I run VRSim as Administrator and LINDA togehter, the left part of the FCU Combo (EFIS and MCP) is working, the USER part works with  predefined functions for the Buttons (maybe fron VRinsigt programmed) and I can not change the functions.

If only LINDA runs, the FCU Combo is not working, the displays show only "FCU-Combo/Airbus VRinsight, Flight" - "Type v1.00 Dream Supplier!" - "Instrument Radio via VRiSim" but the LINDA screen shows that everything is ok.

My LINDA Version is 2.8.6 and FSUIPC Version is 4.959 (registered Version).

Erwin

Share this post


Link to post
Share on other sites

Hi Erwin

My apologises for the short post last night. I just wanted to check out the most probable cause.

My next recommendation is to update to LINDA 3.0.4 and FSUIPC4 4.972 so we are using the same standard.

VRiSIM may display data but interferes with LINDA operation. You only need the FDTI USB-Serial drivers that VRiSIM installs for LINDA to run with the MCP. VRiSIM also helps determine the COMPORT but should then closed.

Make sure that the Setup MCP has MCP enabled, FCU (Airbus) and the COMPORT correctly entered. It is useful to ensure that LINDA works correctly with the FSX Default aircraft before trying your preferred aircraft.

Finally, to allow me to help you please follow the Fault Diagnosis Procedure and email me the logs together with the config-mcp2a.lua files for your FSX Default and preferred aircraft.

Share this post


Link to post
Share on other sites

Hi Andrew,

thank you for your reply.

What I did:

I updated LINDA to 3.0.4 and FSUIPC to 4.972,  removed VRSim completely from my Computer as well as the Drivers (through System control and device Manager),  reinstalled the FCU Compo but only the Drivers. And the Problem still exists.

I am not an IT Specialist, but on my Point of view, LINDA works perfect, only the communication between LINDA and the VRInsight MCP Compo does not work.

I followed the Fault Diagnosis Procedure and mailed you all the files.

Thank's a lot

Erwin

 

Share this post


Link to post
Share on other sites

Hi Erwin

Thank you for sending the log files. The FSUIPC4_prev.log shows that the VRI port 1 com7 failed to open. The later file shows it opening. However, the next line FSUIPC should report is that:

VRI MCP2A ("Airbus") detected on port com7

This is where your problem lies.

Please search for and open the Device Manager. Find entry "Ports (COM & LPT)" and click on arrow to expand. With the VRI Combo switched on you should see a line "USB Serial Port (COMx)" where x should read 7. If it does not then the wrong port is being used in FSUIPC4.ini and LINDA. Right-click on the USB Serial Port and select Driver. The provider should be FTDI. My driver is dated 16/08/2017 and version is 2.12.28.0. If your's is older, click on Update Driver and select automatic check.

Open FSUIPC4.ini in TextEdit and search for block [VRInsight]. It should have at least one entry "1=com7".

Then open LINDA and select Setup MCP Combo. The top left boxes should read:

Enabled = ticked

Type = MCP2a (Airbus)

COM Port = COM 7

Close FSX and LINDA and restart. 

Email me the FSUIPC4.log and your FSUIPC4.ini files. Also send me /modules/linda-cfg/system/config-vri.lua file.

Share this post


Link to post
Share on other sites

Hi Andrew,

The USB Serial Port (COM) reads 7. The entry in the FSUIPC.ini file reads "1=Com7".

Regarding the MCP Combo: The "enable"-box is ticked, the COM Port is 7.

But in the Type box I have only three Options: FCU(Airbus), MCP1 (original) and MCP 2(Boeing) and not MCP2a (Airbus) as you wrote in your reply.

I sent you the files by Mail.

Share this post


Link to post
Share on other sites

Sorry, I was working from (faulty) memory. You correctly have FCU(Airbus) selected. It is also known by its VRInsight name of MCP2a.

Unfortunately, the FSUIPC4.log you sent is incomplete. For it to be useful, you need to run FSX and LINDA, wait until you see LINDA Ready, operate some buttons and then close everything down.

Did you check the Device Manager and driver versions as I suggested? The problem is still that FSUIPC is not seeing you FCU(Airbus) panel which is right at the beginning of SimConnect sequence around line 500. FSUIPC is opening the correct ComPort but is not detecting the panel.

I would reinstall VRiSim to ensure the FDTI USB serial drivers are in place. VRiSim can be present on your machine but it is not required to run when using LINDA. LINDA carries out all communication with your FCU panel through FSUIPC.

Share this post


Link to post
Share on other sites

Hi Andrew,

Yes I checked the Device Manager and my Driver Version is the same as you wrote in a post before. (16/08/2017 and version is 2.12.28.)

I send you again the log file.

Erwin

Share this post


Link to post
Share on other sites

Hi Andrew,

I don't want to disturb you on Sunday, I only want to report, that now almost the whole System doesn't work.

Since the update of FSUIPC and LINDA, my SAITEK Radio Panel and the Multi Panel are lost. FSUIPC doesn't detect the Radio and Multipanel, although LINDA is detecting both Panels.

Erwin

Share this post


Link to post
Share on other sites

Hi Erwin

Sorry for the delay but my job tends to have me working at the weekends. 

I have installed FSX today to see if I could replicate your problem. I have even changed the Comport to 7 to match your's. My MCP Combo panel works everything. I am at a loss to say why you are continuing to have problems. I suggest you make a backup of the /modules folder. Then completely remove FSUIPC4 and LINDA by deleting the /modules folder. Then reinstall first FSUIPC4 and then LINDA. You will need to go to Setup LINDA to set the Comport etc. 

The operation of Saitek Multi and Radio panels is completely reworked in LINDA 3.0.x as explained in detail in the release notes. You need to tick Saitek Panels in Setup LINDA and disable the radio and multi panels in Setup Joysticks. When you start/restart LINDA you will find that the AP LEDs and Landing Gear LEDs will cycle/blink in sequence until you operate one switch/knob. The Radio display will show dashes until you operate a control.

Share this post


Link to post
Share on other sites

Hi Andrew,

thank you for your reply. I will follow your suggestions.

But my Saitek Panels are doing this as you described in your post. The AP Led's are cycling, the Landing Gear Led's are blinking and the Radio Display shows dashes.

In LINDA, functions are assigned to buttons, switches in the Multi oder Radio Panels, but no Response, no Action nothing happend in the sim. Only the Multi Switch Panel is working as expected.

Thank you very much

Share this post


Link to post
Share on other sites

The Multi And Radio Panel functions are hardwired for Default aircraft operation: this is why you disable them in Setup Joysticks. Further work is required by me to operate with more sophisticated aircraft like Airbus.  However, you will find that the Radio Panel works with most aircraft. 

If you wish to programme the Multi And Radio Panels with your own functions you need to untick Saitek Panels in Setup LINDA and enable them in Setup Joysticks. Performance and response is slower  

Only the Switch Panel is fully programmable. 

EDIT this information is in the LINDA release notes included in the downloads. Please read them. 

Share this post


Link to post
Share on other sites

Hi again,

I did what you suggested, but no success. The MCP Compo is not working, and I have no idea, what I should do now.

Anyway, have a nice evening

 

Share this post


Link to post
Share on other sites

Hi Erwin

I have posed a query on the FSUIPC support forum to see what can be suggested.

I assume you have had your FCU panel working before with LINDA or is this the first attempt. Have you had it working with VRiSim?

Can you carry out a self-test of the panel for me? Switch the panel off. Switch Baro Units switch (top left) to InHg. Switch on panel. The radio display should show Test Mode. When you press a button or rotate a knob the buttons should flicker and the 5 char code for the button/knob appear in the second line. 

Share this post


Link to post
Share on other sites

Hi Andrew,

first of all, thank you very much for your working tirelessly, and sorry that I didn't read the release notes completely.

I did the self test of the FCU panel. If I rotate i. e. the speed knob to left it shows "SPD -", if I press a button it shows "ARPT." or "BTN1." for a knob on the user side of the panel. So on my Point of view it is working as is should. I think, the problem is the communication between FSUIPC/LINDA and the FCU combo (but as I told you before, I am not an IT specialist, I am only a user).

Regarding the Saitek Multi and Radio Panel:

What I meant before, I assigned to the HDG knob on the Multi Panel the Airbus function "Autobrake cycle" and in shifted mode "Door front left toggle" via LINDA. It works perfectly. If I understand now the realease notes correct, the Multi/Radio panel is no longer programmable with Airbus modules Function via LINDA, isn't it?

If FSX and LINDA run and I start additionally the VRSim software as administrator, the left side of the FCU seems to be working correctly (I can use the Baro-knob, Speed and Altitude and all the other knobs in the left part), but no response on the right (User) part of the FCU combo and I cannot assign functions to the knobs on the User side of the Panel. And, I pressed the "Lamb"-knob, then the Panel is shutting down.

Only for my understanding: The three modes on the FCU are completely different to the Shifted One - Shifted Two and Unshifted mode for the joysticks?

My questions and explanations seems to be confused, but believe me - I am really confused!

 

Erwin

Share this post


Link to post
Share on other sites
10 hours ago, Eschell said:

Hi Andrew,

first of all, thank you very much for your working tirelessly, and sorry that I didn't read the release notes completely.

I did the self test of the FCU panel. If I rotate i. e. the speed knob to left it shows "SPD -", if I press a button it shows "ARPT." or "BTN1." for a knob on the user side of the panel. So on my Point of view it is working as is should. You are getting the correct response from the self test. It is working correctly. 

I think, the problem is the communication between FSUIPC/LINDA and the FCU combo (but as I told you before, I am not an IT specialist, I am only a user). I agree which is why I asked the FSUIPC developer as to why FSUIPC is not reporting the panel type. A device number is being allocated by FSUIPC but no commands are being received by or data send from the panel.

Regarding the Saitek Multi and Radio Panel:

What I meant before, I assigned to the HDG knob on the Multi Panel the Airbus function "Autobrake cycle" and in shifted mode "Door front left toggle" via LINDA. It works perfectly. If I understand now the realease notes correct, the Multi/Radio panel is no longer programmable with Airbus modules Function via LINDA, isn't it? With Saitek Panels ticked, LINDA no longer allows the Multi or Radio panel to be programmed (this is middle stage in development). If you unticked Saitek Panels and enable each panel, you can assign functions as per Joysticks BUT response rates will be slow.

If FSX and LINDA run and I start additionally the VRSim software as administrator, the left side of the FCU seems to be working correctly (I can use the Baro-knob, Speed and Altitude and all the other knobs in the left part), but no response on the right (User) part of the FCU combo and I cannot assign functions to the knobs on the User side of the Panel. And, I pressed the "Lamb"-knob, then the Panel is shutting down. This indicates that the panel is communicating with VRISIM which is good. However, this is the VRISIM doing all the control and no LINDA programming will be used. It must one or the the other - VRSIM OR FSUIPC/LINDA.

Only for my understanding: The three modes on the FCU are completely different to the Shifted One - Shifted Two and Unshifted mode for the joysticks? Correct - the MCP modes and totally different and separate from the shift modes used for Joysticks.

My questions and explanations seems to be confused, but believe me - I am really confused!

Erwin

Guten Morgen Erwin

LINDA is supposed to be easy but in some cases it can be complicated to sort out some issues like your’s. See my notes above. 

I will continue to help to get things working. Pleas bear with me.

Share this post


Link to post
Share on other sites

Hi Andrew,

thank you that you are working so hard to solve MY problem.

I believe, my computer is living and he hates me.

I configured the SAITEK Panels as you described in the release notes, that means: I ticked in the LINDA Setup the box SAITEK Panels to control it with LINDA GUI and I disabled in the Joystick Setup  page the Radio and the Multi panel. Therefor, the Switch panel should be fully programmable. But not with my Computer. Neither with the LINDA GUI mode nor with the LINDA LUA mode (Saitek unticked in Linda Setup, Panels are enabled in the Joystick Settings) I am able to assign the command "BATTERY BOTH ON" from the Airbus modules to the switch Panel knob "BAT".

This is not really a Problem, as I can assign these functions to the Buttons of the yoke or the throffle quadrand with the shifted modes, but it shall show you, how my Computer is annoying me.

So I will not use the Radio, Multi or Switch Panel for the Aerosoft Airbus, no Problem.

Erwin

Share this post


Link to post
Share on other sites

Hi Erwin

I have received some feedback to my questions but it does not go far to solving your problem. FSUIPC uses the same command calls to the MCP panel that LINDA uses. The problem you have is that neither is

I would ask you to try something. I would like to reset your VRi Combo comport number to one normally used. Please follow the following:

  • Switch on MCP Panel. Do you hear a device connection sound?
  • Open Device Manager.
  • Select Ports (COM & LPT).
  • Find USB Serial Port (COM7).
  • Right-click on it.
  • Click of Uninstall Device and click Uninstall.
  • Switch off MCP Panel.
  • Restart your PC.
  • When running, switch on MCP Panel.
  • Open Device Manager.
  • Select Ports (COM & LPT).
  • Find USB Serial Port (COMx).
  • If it still reads COM7, continue below:
    • Right Click on USB Serial Port (COM7).
    • Select Properties.
    • Select Port Settings.
    • Click on Advanced.
    • Change COM Port Number to COM3.
    • Click OK.
  • The USB Serial Port should now read COM3.
  • Locate /fsx/modules/fsuipc4.ini and open in editor.
  • Under [General] block, add 2 lines:
    • Debug=please
    • LogExtras=x40
  • Search for [VRInsight].
  • Change 1=COM7 to 1=COM3.
  • Save.
  • Open LINDA and select Setup LINDA.
  • Change MCP Comport to COM3.
  • Open Task Manager.
  • Make sure VRiSIM (32 bit) is not listed under Apps. If it is, click on it and click End Task and report that you had to do this.
  • Scroll down and ensure SerailFP2 Flight Panel (32 bit). if it is, click on it and click End Task and report that you had to do this.
  • Close and open LINDA.
  • Run FSX with default aircraft (not Airbus).
  • Fingers crossed. Does MCP panel display change.
  • Email me the resulting FSUIPC4.LOG.

I am not sure whether this will help but I am running out of ideas (for tonight/Heute Abend).

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.