Sign in to follow this  
Driver170

USB device malfunctioned

Recommended Posts

I'm such an idiot! this morning my foot caught my Jetmax TQ USB cable thats plugged into my PC and bent it out. now i'm getting a message saying One of the USB devices attached to this computer has malfunctioned.

I have tried it on my 2nd PC but same message also tried a new USB cable.

 

is it goosed?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Since you have tried a different computer and different cable, it seems you have isolated the problem to the TQ .

I would take a look at the socket where the USB cable connects to the TQ to see if any of the connection 'contacts' are bent, twisted or missing, etc. You can find pictures on the net on what they should look like.  If not, then it is possible you caused a short among those contacts when the cable got ripped out which could have damaged the USB interface logic circuitry inside the TQ. It would also probably be a good idea to contact Jetmax.

Al

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this