Sign in to follow this  
endless_discovery

P3D & Nvidia surround major CTD issue.... Please help!!!

Recommended Posts

Setup: Win 7, P3D on three 23" monitors using Nvidia surround.

Issue: Random CTD usually within the first 5-10 min of flight usually with a msg that the display driver has failed or a .dll failed to load.

Tried so far:

-Clean install

- Different versions of drivers

-Delete/replace corrupted .dll . xml files etc..

-almost everything else that's been suggested on the forums...

Conclusion: After almost a week of breaking my head with this CTD issue i figured the only way i dont get any CTD's is by not using Nvidia surround and simply running P3D on a single monitor. But i very much like the 3 monitor set up. I must admit my GPU is 5+ years old (GTX 650 Ti Boost).

Do i need to upgrade the GPU or is there any other way around it. Please help this poor simmer folks!

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you checked our Monitors Forum in the Hardware Section?  I pinned a topic on setting up 3 monitors. I personally have never had any success whatsoever using multi-monitors for FSX or P3D. The GTX 650 TI, although old, should be able run 3 monitors.  The display driver has failed error was a common CTD back in the old 2012/2011 days.  Did you check the possible solutions at the following link from Microsoft https://support.microsoft.com/en-us/help/2665946/-display-driver-stopped-responding-and-has-recovered-error-in-windows-7-or-windows-vista?  As I recall, Method 3 solved my problems.

Best regards,

Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this