Hoang

Long freeze when saving flight

Recommended Posts

Hi,

I am having a big issue with saving flight. Whenever I save a flight through P3D menu or Pro-ATC/X, I have a very long pause, for FSLabs A320X around 30 seconds, PMDG 777 takes around 1 minute to save. It has been working fine for me using Pro-ATC/X auto save situation where it will autosave without any pause in the sim.
I am not using FSUIPC autosave.

By looking at FSUIPC.log, I found that everytime I save a flight, one of these 2 messages pop up

"**** No SimConnect events or states being received! Re-connecting now ... ****"

" **** SimConnect Data Stalled! Re-connecting now ... ****"

I just installed PMDG 777 yesterday and could not get it to work, had errors with simconnect, I reinstall all the simconnect file and it still did not work. I installed Addon Manager from FSDT and the aircraft works. But it seems that simconnect still having issue in my simulator.

Anyone know what could have cause it?
Thank you,
Hoang Le

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Whenever I save a flight, in Process Monitor it shows P3D takes a lot of time to load these 2 (loads during the time simulator hang up)

"D:\Game\Lockheed Martin\Prepar3D v3\FSLabs\A320\PanelState\LastProATCX.fxml.sav"

"C:\Users\******\Documents\Prepar3D v3 Files\KLAXKSLC_20170410-0901_RTE-EnRoute_142.fxml"

 

I reinstall PMDG 777 and now I cannot get it to load again, and this time even reinstalling Addon Manager from FSDT doesn't help.

I open Process Monitor and P3D keeps loading 777X_debug_log.txt , open a ticket over PMDG and got the answer that this relates to Simconnect.

Can anyone check if I have the correct version of Simconnect?

"Running in "Lockheed Martin® Prepar3D® v3", Version: 3.4.22.19868 (SimConnect: 3.4.0.0)"

Thank you,
Hoang Le

Share this post


Link to post

I had a similar issue and I simply updated to the latest fsuipc version and the problem went away.

Share this post


Link to post
7 hours ago, MVelasquez said:

I had a similar issue and I simply updated to the latest fsuipc version and the problem went away.

Hello,

Yes that is what I did plus change the SimConnectStallTime from 20 to 1 (default is 1). Restart my window and everything works normally again.

Here is the full topic over at Pete's forum. He was very helpful in solving the issue with me.

http://forum.simflight.com/topic/83164-simconnect-stall-and-re-connecting/


Cheers,
Hoang Le

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now