DiogenesMuc79

Error 3 "Cannot write to dx10.ini in AppData\DX10SceneryFixer (0)

Recommended Posts

Hi there,

a few days ago, I switched to FSX SteamEdition. After reinstalling DX10SceneryFixer (DX10SceneryFixer_3_2_98, it was uninstalled first before removing FSX DVD Version) I installed the librarys without problems. But if I want to set preferences or settings in DX10SeceneryFixer i alwas get this error message:

"Cannot write to dx10.ini in AppData\DX10SceneryFixer. (0)
System Error was 3"

I am running FSX:SE on Windows 10, logged in as normal user. DX10SF was installed and started as the FSX:SE and Steam itself as Administrator. Principally the above named path does not exist either in admins personal folder nor in users personal folder but exists in users AppData\Local\. Copiing the Folder to the in the error message named place does not solve the problem.

What to do?

Yours,
Sebastian (EDDM)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The error is a little misleading.   What it is doing is looking up the Path associated in windows with the key CSIDL  LOCAL  APPDATA

That should return appdata\local of the user who is running dx10controller.

so e.g c:\users\steve\appdata\local

then it appends to that DX10SceneryFixer and tries to write to the dx10.ini in that directory.

error 3 is invalid path so the directory does not exist.

i would guess that you installed the fixer for one user but are running it as a different user who does not have the dx10sceneryfixer directory under local appdata

i cannot quite tell from your description how many users you have in windows.

Share this post


Link to post
Share on other sites

Hi Steve!

thanks for Your answer. With your information i tried to install the tool other than before not from my user account with admin rights but from administrator account itself. And ... it worked.

It seams, that installing from user account with admin rights ist not the same...

Problem solved!

Thank you.

Yours,
Sebastian

Share this post


Link to post
Share on other sites

Thanks for letting me know. It's my opinion that the fixer should deal better with the scenario so I will change it to create the directory if it is missing.

 

and yes, you with admin rights will still be using your local appdata whereas the administrator user will be using his local appdata if that makes sense.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now