Recommended Posts

If one adds a 'response/reply' when entering a Voxkey command, when running the defined command the voice used in the defined response is not the same voice as one's configured FO voice. Is this a bug or is there a reason?

Cheers,

Stuart

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I assume this is beacuse only a TTS voice is able to read any text you enter there whereas the vocabulary of the recorded voices is limited. So I guess always a TTS voice is used for the voxkey response - not sure which one is chosen though.

 

Workaround:

Instead of creating a voxkey command "Gear down" triggering "G" and responding "Gear down" you create the voxkey command "press key G" triggering "G" with no repsonse.

Then you create a voicescript "Gear down" with "press key G" as only the only command under [Script] and with the "Reply1=Gear down".

So your chosen voice will be used. Downside is that you cannot run this if another voicescript is already running of course.

(The example "gear down" is obsolete of course because this is included in the standard commands of MCE.)

 

Share this post


Link to post
Share on other sites

Thanks Ralf,

Good suggestion, but I think I'll just remove the reply from the Voxkey command.  I currently using it in my Voxkey command to communicate with PF3 - "let's request clearance", it just sounds odd when I get an American voice responding "ok, cap will do", when my MCE FO is English, or even sometimes French!

Hopefully the need for Voxkey commands to interface with PF3 may be a thing of the past once the next MCE update is released.

Stuart

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now