CajunRon

FSX DX-10 Long Pause Problem

Recommended Posts

After years of relatively stable operations I've run into a problem that seems to occur to a few of us but which I have not been able to find a fix.   The problem is "long pauses" where FSX DX-10 freezes for 5 to 10 seconds and then resumes.   I've done extensive on-line research and tried all of the possible fixes I could find but none have solved the problem.   These included

1.  Run DXTFIXERX to fix any texture files without alpha channels (or something to that effect)

2.  Reduced the graphics sliders

3.  Tried numerous fsx.cfg tweaks

4.  Delete fsx.cfg and let a new one be built on startup

5.  Disabled hyperthread mode in BIOS

6.  Disabled (by renaming)  exe.xml and dll.xml to stop any add-on programs and modules from running.

7.  Removed custom NVidia Inspector settings and loaded defaults into FSX profile.

and numerous others.

I set up my affinity mask (with hyperthreading off) so that FSX used Core 1,2&3.  I left Core 0 for other processes.   I then monitored the processes running and the % utilization of each core using "System Monitor".   What I discovered was that when a "long pause" occurred,  the process labelled "System" running on core 0 would jump from 0 to 2 % core use up to 15 to 20% core use.   Simultaneously, in most cases, Cores 1,2,&3 (where FSX is running) would DROP from about 50% utilization to maybe 15% or less.  The process label for "FSX" would momentarily turn red and report "not responding".   The fact that the "long pauses" seemed to occur pretty much in the same locations in the flight (taxi, takeoff and approach) but not often in cruise flight seems to suggest that what ever "System" process is doing, it is related to FSX.

Not sure what else to try other than a complete uninstall/reinstall but if the problem is a "System" interference I fear that would not solve the problem.

Anyone have any other ideas?

System specs: FSX DX10 (with DX10 fixes), Intel i7-4770K overclocked to 4.3 GHz,  NVidia Geforce GTX 780 no overclocking, 8 G ram, CH Products Yoke and Throttle, Saitek rudder pedals, TrackIR 5, FSX and all third party add-ons installed on dedicated Samsung Solid State Drive.

Thanks.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Well this is odd! I run into this problem this Monday (15.05.2017) for the first time. I just reverted to a vanilla FSX:SE setup to run some tests with FSMark. I ran many many loops of the tests and added "things" (tweaks) to my cfg to see the outcome. I've run at least 10-12 loops in DX10 (no fixer) with no problem and many more loops in DX9 before that.

Also after applying the fixer, I still did ran ~6 loops without a freeze. Since I was getting a bit more performance in DX9 (~4FPS avg), I unistalled fixer libraries and the fixer itself for more DX9 testing, and my FSX went ballistic. It froze on every single run of FSMark. I could see some strange behaviour in CPU load and could find the culprit. I'm now on the point of formating the system and start new.

I also remember that shortly before the freezes, Windows has done something (maybe an update of a kind, I didn't had the chance to look it up) because I've seen "unplanned" core activity (I ran FSMark with Task Manager open to see how the CPU load and speed performes).

I already had the latest nVidia drivers 382.05 and it did not update those (was the first thing to check).

Today I will investigate again this issue...but a hint for you: look if Windows did update something on Monday...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now