MarkN1232

another SDK question

14 posts in this topic

Before I ask this question, I've done the research, read the forums and still have a problem with  the FS2Crew SDK error for the PMDG 777. I can't find the file 777X_Options.ini that is located in the PMDG\PMDG 777X file to add "SDK and EnableDataBroadcast=1".  I have:

 >Aircraft

>Manuels

>Panel State

>SDK (when I open this file there is no 777X_Options.ini)

 

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Mark,

The 777X_Options.ini file is not in the SDK subfolder. The 777X_Options.ini file can be found in the '[Sim installation folder]\PMDG\PMDG 777X' folder. Within this 777X_Options.ini file there is a [SDK] section, and within this section you have to set the EnableDataBroadcast key to 1:

...
[SDK]
EnableDataBroadcast=1
...

Maarten

0

Share this post


Link to post
Share on other sites

Not quite sure I understand what your saying. I'm going to: Lockheed Martin>Prepar3d>PMDG>PMDG77X. After that I don't see anything with 77X_Options.ini

0

Share this post


Link to post
Share on other sites

Hi Mark,

I don't understand what you mean by I'm going to: Lockheed Martin>Prepar3d... Is that the folder where Prepar3D is installed on your machine? Furthermore: it's not the 'PMDG\PMDG77X'  subfolder where you have to look, but the ' PMDG\PMDG 777X' subfolder. if there's no 777X_Options.ini file in the ' PMDG\PMDG 777X' subfolder of your Prepar3D installation folder (which is very unlikely), you will have to reinstall the 777 I'm afraid.

Maarten

0

Share this post


Link to post
Share on other sites
4 minutes ago, mawibo said:

you will have to reinstall the 777 I'm afraid.

This is not entirely correct. You simply have to run the sim once (and make sure you do so as an administrator).

0

Share this post


Link to post
Share on other sites

Hi Mark,

As Kyle said: did you run the sim again after you reinstalled the 777 and did you activate the 777 when you tried to use it?

Do you perhaps have 'Hide extensions for known file types' turned on in your Windows Explorer settings? If so, type 'File Explorer Options' in Window search (or open Windows Explorer and select File|Options), select the View tab and uncheck 'Hide extensions for known file types'. After that, try to find the 777X_Options.ini file again. You can also go to Windows Explorer, select the Prepar3D installation folder and type '777X_Options.ini' in the search box next to the address bar.

Maarten

0

Share this post


Link to post
Share on other sites

I'm going to uninstall then reinstall then run P3D as administrator.

0

Share this post


Link to post
Share on other sites

ok so after I reinstalled the program I get this message:

PMDG 777 NOT FOUND:

"C:\Program Files (x86)\Lockheed Martin\Prepar3Dv3\PMDG777X\777X_Options.ini

I have both the 200 and the 300ER installed

0

Share this post


Link to post
Share on other sites

Hi Mark,

Which program is generating this message? Did you manually type the error message in your post or did you copy and paste it? The reason I ask is because the correct folder should be "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\PMDG\PMDG 777X".

Maarten

0

Share this post


Link to post
Share on other sites

Gents,

This is one of the many reasons why I stress that uninstalls/reinstalls are neither necessary, nor are they recommended unless it is a known fix. Since you've already done the uninstall/reinstall (against my earlier note that it was unnecessary), please simply run the sim as an administrator and use the 777 for one flight, and properly close the sim. As Maarten questioned, however, what program is generating the error message? I don't recall it being one of ours, since ours will ignore the fact that it is not there if it is not present, and create the options.ini if it doesn't exist when the 777 is next run.

0

Share this post


Link to post
Share on other sites

Ok how do I navigate to the FSX.exe file? According the FS2Crew  I need to right click then "run as administrator" under properties. Problem is I can't find it.

0

Share this post


Link to post
Share on other sites
4 minutes ago, MarkN1232 said:

Ok how do I navigate to the FSX.exe file? According the FS2Crew  I need to right click then "run as administrator" under properties. Problem is I can't find it.

In your first post, you noted that you were able to navigate into the folders containing the various parts of our aircraft. Those folders are within your main sim directory. The main sim directory will also have the [sim].exe file. They may have said "FSX.exe," but based on your other responses, I believe the correct program you're looking for is "Prepar3D.exe."

For me, this is in the following folder:

P:\Prepar3D v3\

0

Share this post


Link to post
Share on other sites

Yes I'm using Prepar3d, Found it!!

 

Thanks

0

Share this post


Link to post
Share on other sites