GAJ52

Database Error Problem

Recommended Posts

I am trying to install Pilot2ATC on a new computer (clean version of Windows 10).

Initially tried version 2.2.1.6 then 2.2.1.7, both versions had the same problem.  After installing, a message appeared saying something about 'faulty installation package'.  It then tried to load P2A but the loading screen only went up to 10% then a fault window appeared saying

Database Error

Unable to initialize Database - The underlying provider failed to open.

A network related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible.  Verify that the instance name is correct and that SQL Server is configured to allow remote connections.  Unable to locate a Local Database Runtime installation.  Verify that SQL Server Express is properly installed and that the Local Database Runtime feature is enabled.

This happed after installing 2.2.1.6 then again after 2.2.1.7, I have given Pilot2ATC_200.exe Administrator rights but still can't load and use Pilot2ATC ?? 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Glen,

One other user had the same problem.

I'm uploading a new installer that should work.  It will be version 2217a and should be on the web site in a few minutes.

Dave

Share this post


Link to post
Share on other sites

The new version 2217a is on the web site and should fix the DB installation issue.

Edit:

The fix does not work.  I will get it working and post when it does.

Dave

Share this post


Link to post
Share on other sites

OK.  I was able to duplicate the problem, found the real cause in the installer package, and was able to get it to work.  SO THIS ONE OUGHT TO BE GOOD.

Sorry for all the problems some of you had.  The new package is 2.2.1.7b and is on the web site now.

The problem was that the SQL LocalDB installation file was not part of the package and when the installer tried to install the SQL LocalDB, it couldn't. 

You should be able to just run the new installer and all will be good.

Thanks and again, sorry.

Share this post


Link to post
Share on other sites

Hi Dave.

I'm Giorgio from Italy.

Today I bought the application and during taxiways import procedure (that I've followed as described in the documentation) I got the following two problems:

- Program suddenly closed;

- the exe file disappeared under installation directory; I tried to find it using Explorer in my PC without success.

After that I tried to uninstall the application and after a PC reboot I proceeded to install it again. The result is that now I've the same error message that Glen reported you one year ago (that's the reason why I use the same topic).

What I have to do? 

Thanks for your support.

Ciao, Giorgio.

Share this post


Link to post
Share on other sites

You should be installing the full package with either the Navigraph or NavDataPro data included.

If that is what you installed, then check in the Data sub folder and be sure you have the P2ABaseData.mdf file and the P2ADynamicData.mdf files.  Also, try deleting the corresponding log files P2ABaseData_log.ldf and P2ADynamicData_log.ldf files.

If that does not solve the problem, please email me (admin@pilot2atc.com) a screenshot of the error message and I will help you get up and running again.

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now