Sign in to follow this  
stephowz

can't install 777 immersion P3D V.4

Recommended Posts

I try to install 777 immersion. When I click direct install I found " You need to have at least one compatible simulator installed to use this product"

   My sim P3D v.4, I have FSUIPC v.5 full version register complete . help me please

image-FBEE_59524C4E.jpg

image-F358_59524F89.jpg

image-33B5_59524F89.jpg

 

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The reason you see P3Dv4 in the menu option is because of ChasePlane. The  immersion packages have not been updated yet.

Share this post


Link to post
Share on other sites

sorry .. but .. I feel that (not finished TFDi 717) have higher priority as fully working PMDG 777.... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this