Sign in to follow this  
jetsmell

Typing not working in fixer.

Recommended Posts

I opened the FSX Fixer for the first time and tried to type the FSX SE path in at the top and the keyboard is not working there. I can type here and

everywhere else but there.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You use the Change Button to set the path using a browser dialog.  (Pg 23 of manual).

Share this post


Link to post
Share on other sites

The change box is greyed out when and if the libraries have been installed.  If you uninstall the libraries then the change box will be enabled.

This logic is a safety check  to prevent someone switching systems and accidentally orphaning an updated system with no way then to restore it.

When reinstalling fsx and/or changing its path  or uninstalling/reinstalling the fixer you must therefore first uninstall the libraries as per the manual.  The information on whether the libraries are installed persists over a fixer uninstall/install to avoid errors trying to update a fsx system that is already updated.

Failing to do this can lead to a situation where, the fixer believes that the libraries are installed but the fsx system no longer exists and the uninstallation cannot therefore work.

(All Fixer updates can be applied without issue and do not require an uninstallation)

There is a workaround for this deadlock issue in file->preferences   the last option is an emergency override which disables the safety checks and just allows you to change the path.  However depending on the actual state of the fsx system you may get various pop up errors but it should all resolve itself

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this