vbazillio

Crash to desktop when trying to access "LOAD" scenery

Recommended Posts

I'm currently fighting with a new issue for me. My P3D v4 was working great until then.

I have the "Prepar3D Scenario" screen to show at every startup. If I click "Load..." I immediately receive "Are you sure you want to exit Prepar3D ?" YES/NO pop-up. If I reply YES, Prepar3D crashes to desktop. If I click "NO", Prepar3D loads with the "Prepar3D Scenario" window still on top of the regular Prepar3D progress bar and main window.

Inside Prepar3D, if I choose from the menu SCENARIO, then LOAD, P3D hangs and crash-to-desktop.

Remark :
- Prepar3D v4.0.28.21686 PRO (HF1 - Content only)
- When Crash-to-desktop, event viewer indicates KERNELBASE.DLL has faulty
- Windows 10 creators Update
- Antivirus deactivated for Prepar3D folders and process

Tests done so far : re-install nvidia driver, update nvidia driver, uninstall GeForce Experience (suspected Shadow Play), because of this thread http://www.prepar3d.com/forum/viewtopic.php?t=119319 I suspect a USB issue so I unpluged everything except the keyboard, change from mDP to HDMI my main monitor, de-activate all addons via exe.xml, dll.xml, addons, delete Prepar3D.cfg, delete \users\<MonNom>\Documents\Prepar3D v4 Files, re-install HF1 Content.

Any help is welcome,
Thanks in advance,

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

So you did NOT update HF1 Client?  That could be an issue. I'm guessing but perhaps the UPDATED CONTENT conflicts with the NON updated client?

Vic

Share this post


Link to post

You mean I didn't update the CONTENT ? 

That's right I just updated the client. And it worked just fine two days until I encountered what I described. 

Oups ! My apologies. I wanted to write "HF1 Client" and not "HF1 Content". I have only updated the "HF1 Client"

Share this post


Link to post

Problem solved.

I have the whole IVAO MTL library installed. If I wanted to speed up the loading of Prepar3D I used to rename the IVAO_MTL folder. Doing this in Prepar3D v4 HF1 makes the program crash to desktop.

I simply rename IVAO_MTL accordingly to the simobjects.cfg file to correct my problem. Now, if I want to avoid IVAO_MTL I have to modify simobjects.cfg (set ACTIVE to false).

Share this post


Link to post

Glad you got it sorted!

 

Vic

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now