Sign in to follow this  
Mejjo

Jagged Edges Situation

Recommended Posts

Hello,

I mostly use the PMDG aircraft and have posted on their forum too but it seems my problem is to do with using the DX10 fixer.

I am running FSX:SE and i've followed the instructions precisely. When i'm viewing a wing view i always have jagged edges on the outline of the control surfaces. If i use DX9 it goes away with my AA settings etc.. I have set the AA with the fixer to the highest possible to see if it corrects the problem but it doesn't. It seems the DX10 fixer isn't properly applying the AA in the sim maybe? It could be something i'm missing. I'm really not too sure so i wanted to ask here to see if anyone knows.

The frustrating thing is using the fixer with DX10 makes my sim run so much smoother, If i could just eliminate those jagged edges i'd be happy.

I will post a pic too :) 

20170712124209_1.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If you tick the AA box in FSX setting it actually selects 2x AA for DX9 and 4x AA for DX10.  

This standard form of AA  acts on the edge of 3D objects like the edge of the wing  but not on textures applied to 3D objects. When saying this note that many things that in the real world are 3D objects are just textures within FSX

Using Nvidia Inspector it is possible to override FSX and force higher levels of AA in DX9 although there is very little gain above 4x in my view.   In DX10 you have to do this via a setting in fsx.cfg To simplify this a little the controller provides a setting which writes the fsx.cfg entries for you .(so long as you run it as the same user that you use to run fsx).  Occasionally people have a separate  admin user and run fsx as that user and so the controller will not be setting the right settings unles sthey run it as the admin user.

FSX with 4x AA should look the same in DX9 and DX10

That is only half the story though - the most important thing is not the AA setting but rather the supersampling setting because it applies to the whole screen.   This can only be set in Nvidia Inspector.  For DX10 the only type of supersampling that works is Smart Grid Super Sampling which is what you should always therefore select with DX10.

One  difference between DX9 and DX10 is that in DX9 there are some combined modes available in DX9 that act to blur the image which some people like.  Theway to replicate this in DX10 is to use 2x DSR in addition the to SGSSAA setting.

When you run FSX in DX10   is the AA setting ticked in settings?  Have you selected  a filtering option in the same settings?

 

 

 

 

 

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Steve,

Thank you very much for taking the time to get back to me. I have just gone back and had a look at the settings and i do have the AA box ticked in FSX. I also have the filtering option set to Anisotropic. I am running the fixer and FSX all on the same user account and i'm making sure everything is running as admin. I want to also thank you for that information on the variety of settings, I have learnt something new there.

I'm wondering if my problem is with nvidia inspector, Is it likely there is something in there causing the issue? I mean all the of the settings have been set per the manual for DX10 fixer so i made sure i followed that. 

Share this post


Link to post
Share on other sites

The only setting in NVidia inspector that has any real impact is the Anti Aliasing Transparency Supersampling method which should be set N x Sparse Grid Supersampling where N matches the setting in the DX10 controller.

140 fps with a PMDG aircraft in clouds seems a little high to me if it is working.

I am sorry but its impossible to say much more,  I cannot tell anything from a compressed screen shot.  As I zoom out lines within a texture will sometimes become slightly jagged in DX9 and DX10 as the GPU tries to interpolate the samples between the actual mipmaps shipped with the textures.

 

 

 

 

 

Share this post


Link to post
Share on other sites

Hi Steve,

 

I think i have found the problem. In Nvidia inspector the FXAA setting i had off. If i turn this on it seems to take care of the jagged edges on the wing, However i seem to then have blurry textures in the cockpit. Is there a way around this? Or will i have to put up with one? 

Share this post


Link to post
Share on other sites

I tried turning FXAA on.  It obviously makes a big difference in the free flight screen as there is no AA othewise set by the sim.

 In the Sim  itself with  no supersampling  but FXAA turned on the VC was a lot less sharp.  In the VC what you need is supersampling to create sharpness as its all about fine details in the textures.

One thing that occurs - is your texture max load set to 1024?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this