Recommended Posts

Hi chaps, 

Im a newby to this forum, & was just wondering if anyone can help me before I pull out my hair and lose it;0) I've got FSX (non steam) running on triple monitors with a half decent pc. When I load up fsx I get the flashing mouse cursor issue. I have read on the forums that there is a fix for this (by editing the 2d panels in the cfg file) I was just wondering if anyone could advise me on what to do to edit them.

(I did read that there is a fix by George Trovato but I couldn't find it)

my screen resolution is 5853 by 1080 (bezel corrected) 

also, another issue is a g2d.dll CTD which I get regularly. Not sure wheat this is or if there is a fix.

any advice would be very much appreciated. 

Many thanks, 

 

ryan 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If you get the spinning cursor in Surround multi monitors when selecting a view try this for each model.

I picked this up from another user on avsim  (PWJT8D ) , VERY gratefiul to him and credit should be given to him

 just back up the panel.cfg first  then try changing each view by adding this;

find the brackets for the windows such as [Window00], [Window01] and so on.

Within each window you'll see a line that says size_mm=1280,960 or whatever that window size may be.

All you need to do is add a line right under the size_mm= line that says pixel_size=1280,960. That pixel size line is what will resize the window properly and not cause the spinning cursor.

So what ever the resolution size of the size_mm= numbers are, copy those into the new line you add pixel_size=.

eg on The Katana 4X  the original panel.cfg had

[Window00]
file=
size_mm=1280
window_size_ratio=1.000
position=7
visible=0
no_luminous=1
ident=MAIN_PANEL
window_size= 1.000, 1.000
window_pos= 0.000, 0.000
zorder=0

I changed to

[Window00]
file=
size_mm=1280
pixel_size=1280
window_size_ratio=1.000
position=7
visible=0
no_luminous=1
ident=MAIN_PANEL
window_size= 1.000, 1.000
window_pos= 0.000, 0.000
zorder=0

etc for each  [window]   then MOST of the Shift 1,2,3,4 views etc dont give you the spinning cursor

This has woirked 99% of the time including my A2A planes, best tip I ever found for multi monitors

Share this post


Link to post
Share on other sites

I have only had the spinning cursor when I tried to save a flight with 2D panels on different screens. This will only be a factor is you have additional screens to your 3-screen main display. I assume you are using nvidia Surround. If you have the same problem, the only solution I have found is to NOT save situations like this. If you do, then loading one gives the spinning cursor and you can't get rid of it except by quitting FSX then loading it with a different flight. If you have this as the startup flight you have to edit fsx.cfg to delete the startup flight, then it resets to default when you next run.

Share this post


Link to post
Share on other sites

Thanks for all your help, I've now managed to find the panel.cfg file, just wanted to check something. After I've edit the the pixel size, when I go to save its only giving me the option to save as a word doc. Is that going to be okay, or is there something else I need to do so it's saved as a cfg file? It's my first time tinkering with files so just wanted to make sure I don't create more problems!!;0)

Thanks again 

 

 

 

Share this post


Link to post
Share on other sites
7 hours ago, RyanFSX said:

its only giving me the option to save as a word doc. Is that going to be okay

NO. Don't edit it with Word, use notepad.

Share this post


Link to post
Share on other sites

iv'e opened it with notepad, but when i click file / save, the default  'save as type' option shows Text Documents (*,txt) with the Encoding option underneath  as 'ANSI'

if i click the 'save as type' drop down the only other option is 'all files'

(also, when i try to save it says 'PANEL.CFG already exists, do you want to replace it?

 

i havent gone through and saved it yet as thought it might be wrong, just not sure how to make sure its saved as a cfg file and nothing else

 

Share this post


Link to post
Share on other sites

Back it up before saving i.e. Copy it away to another location so you can put it back if you mess it up 

edit in notepad  you can save it as .txt. Then just delete the .txt extension and change it to .cfg

 

alternativly set in Windows folder options to open .cfg files with notepad  then you just open it by double clicking the file make changes close the file and say yes to save changes 

 

Back it up first !!

cheers 

Share this post


Link to post
Share on other sites

Thank you very much, no flashing cursor 🙌🏼 The panels load up quite small but now I can resize them manually. (The file save issue was due to permissions in the security cfg file...🙄) 

again, thanks very much 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now