Sign in to follow this  
Debowing

Instrument Power

Recommended Posts

Turning on the instrument power using the three switches with the red bar turns on the noisy whine. Is that normal? And the red indicator light is always on, indicating that there is no power to the instruments. Turning the AFE on or off did not affect this.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Please sign with your real name as per forum instructions.

The switches with the red bar is the Emergency Instrument Power and Inst. Lighting Switch this is to be used in emergency. The whine is normal with this switch.

I would suggest to go over the POH or check my brief tutorial video below

 

 

Share this post


Link to post
Share on other sites
2 hours ago, Debowing said:

Turning on the instrument power using the three switches with the red bar turns on the noisy whine. Is that normal? And the red indicator light is always on, indicating that there is no power to the instruments. Turning the AFE on or off did not affect this.

Welcome to the forum. Full names - first and last - are required in posts here.

See the above post for the answer to your question.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this