wardp

Mouse Look - Erratic views - Fixed.

Recommended Posts

Kevin

In another thread where someone was asking about uninstalling Chase Plane I said that I had the following issue

"However I do have an issue with Chaseplane in P3Dv4 in that whenever I toggle the mouse look on, my view will jump to some random position before I can use it to look around the cockpit so I am also considering going back to Ezdok for the time being."

I realised that I did not have the problem in P3Dv3.4 so it shouldn't be anything to do with the CP settings so I checked all my settings to make sure there were no conflicts with other view, key assignments and hat switches etc but no luck with all that. However the only thing that was different between my P3D v3 and v4 setups was that with the V3 CP was launched automatically when the sim was started. With P3D v4 I started CP manually after the sim was loaded. Na it couldn't be that - it was now CP starts when P3D v4 is started and all is well with no erratic camera views when the mouse look is turned on.

I thought I would post this as it may help others.

Regards

Phil 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Beautiful little gold nugget, thanks for your research on that one.

In V4 with autolaunch, do you show the interface at least once after CP's launch or do you keep it minimized and go fly?
This could have something to do with the fact that the interface is not initialized when panning with the mouse. I will have a look in this area of the code.

Let me know,

Regards,
Keven

Share this post


Link to post
Share on other sites

Kevin

When the sim is started it is in a Full Screen Window and the CP window is behind the P3D window. Normally I just change my departure airport, load the flight plan (prepared in PFPX) switch the aircraft then go flying and switch the sim to Full Screen mode using the menu-view-full screen option. The CP window is floating around somewhere as I do not minimise it to the task bar. Occasionally I have gone back to a full screen window and then to the CP window if I have needed to change something like a shortcut key.

This hasn't changed from starting CP manually or automatically with the sim. Since changing to auto start CP I have flown several flights with the PMDG 737, 777 and 747 and all have worked perfectly with CP.

Hope this helps.

Regards

Phil

Share this post


Link to post
Share on other sites

I pushed a new version. can you tell me if the issue is resolved?

Share this post


Link to post
Share on other sites

Just tested the latest update and it appears to have fixed the problem. CP now works OK in P3Dv4 whether it is started manually after the sim or automatically with the sim.

Thank you very much.

Phil

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now