Moonwolf

Massive stutters in P3D v4

Recommended Posts

Today I tried FFX 1.80 for the first time in P3D v4, but flying was impossible with massive stutters every 2 seconds.

At first I thought Goggle Earth might be the cause, but the stutters continued after disabling GE.

By the way the Goggle Earth mapping is a fantastic feature!

I assume the stutters are somehow related to the particle emitters from smoke effects, but smoke were nowhere to be seen?

After closing FFX flight could be resumed as normal.

Thanks

Michael

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Michael,

issues like these are in most cases related to an installation error. The SimObjects that come with FireFighter X are not visible to the simulator, so every time it wants to show a fire or drop object, an exception happens in the sim. Exceptions are "expensive" in terms of performance, thus the stutters.

- Make sure that you use the correct "_P3D_V4" installer.

- Did you change the default installation path of FFX in any way?

- In the P3D menus, "Options-> Add-ons" there must be an entry "Lorby-SI Content", and it must be enabled.

I had another customer with the same problem, and a simple reinstall fixed it.

Best regards

 

Share this post


Link to post
Share on other sites

Installing to default path solved this and everything is smooth now.

FFX looks even more beautiful in P3D v4.

Share this post


Link to post
Share on other sites
3 hours ago, Moonwolf said:

Installing to default path solved this and everything is smooth now.

FFX looks even more beautiful in P3D v4.

Hi Michael,

so this issue is caused by changing the default installation path? I will take a look at the installer, it should be possible to do something about that.

Many thanks for the hint!

Edit: OK, done. The issue will be fixed in 1.81.

Best regards

Share this post


Link to post
Share on other sites

Hello, I have these stutters now with 1.81 in P3DV4 and I have used the default install path, also tried to reinstall it and also tried to move the objects into the Sim Path, but nothing works. My P3D is crashing, when I drop water on the fire. I'dont know why, but I don't have in Add-ons (when P3D is executed) the Lorby entry, but it is enabled in the add-ons.cfg in AppData\Roaming\Lockheed Martin\Prepar3D v4. Maybe you have a solution for this problem. At the moment everything is installed with the default installation path.

Best Regards

Robert

Share this post


Link to post
Share on other sites

Hello Robert,

this could also be an installation error of some sort. Somehow the SimObjects and the effects necessary for FFX to work are not present. Please don't move files around manually, that can go very wrong. FFX is supposed to be external.

From what you write I assume that the external content is not accessible for the sim, maybe due to a fault in the add-ons.cfg (for example an incorrect encoding). You then copied the SimObjects into the P3D folder, but did you copy the Effects files that belong to them as well?

The content folder should be here:
C:\Users\...\Documents\Prepar3D v4 Add-ons\Lorby-SI Content

The add-ons.cfg should have UTF-16 encoding. Do not try to edit it with Windows Notepad, that will probably break it.

What I don't understand is that you are saying that you see fires - that shouldn't be the case. That would mean that part of the objects and effects are there, but not all of them. Make sure that you don't have duplicates (the same FFX SimObjects in the sim main folder and outside of it).

 

Edit: I keep forgetting this: please check for a logfile in C:\Users\...\Documents\FireFighterX_P3D_V4 Files. If there is one, they are often relatively large - so don't post it here please. Send that to me via email.

Best regards

Share this post


Link to post
Share on other sites

Everything is on default now and I deletet the files from the P3D path,that was just a test with the moving. I don't got a log file in that folder,only got the Ffx_Aircraft_Config_DB_P3D_V4.xml and Ffx_Model_DB_P3D_V4.xml in that folder.And I see everything and everything is working,but it is stuttering and sometimes crashing,when I drop the water on the fire. I also tried the lower settings of FFX.

Best Regards

Share this post


Link to post
Share on other sites

Hello Robert,

I am sorry, but I don't have this problem in my sim(s), so I cannot troubleshoot this issue from here.

- how exactly do those stutters manifest, what does it look like (regular every x seconds, all the time, intermittent, light, severe?).
- Is it related to a specific window being open? Try to minimize the FFX windows and close the subdialogs, to see if that makes a difference.
- Which aircraft are you using, are you using the attachement logic? Does it happen with every aircraft?
- Did you uninstall the old version before you installed the new one?
- Are there other apps or addons running alongside FFX? 
- You didn't have this with 1.80?
- How many fires are usually active?

Best regards

Share this post


Link to post
Share on other sites

Hello,

-everything is working fluently until I push my Joystick button for release droppable objects

-it happens with every aircraft/helicopter,also used the attached objects

-I completely uninstalled the old version

-didn't had this huge problem with 1.80

-only one fire from the VIIRS data

-I didn't run any other apps while flying

-noticed while dropping some errors with the effects, they are getting to squares sometimes

 

Best Regards Robert

Share this post


Link to post
Share on other sites

Okay,the problem is occuring then pusing release droppable objects and when the water effect comes.

Share this post


Link to post
Share on other sites

Hello Robert,

do you hear the sound of the water when it is dropped? And is the issue the same when you use retardant?

On the timer and coverage selector dialogs you can select the visual density of the drop and the size of the "clouds", I suggest that you try "small" and density 1, see what happens.

Is there something else that could be triggered by this event? A smoke effect? (but that would only happen if you have selected that option)

Best regards

Share this post


Link to post
Share on other sites

In any case, maybe it would be advisable if you contact me via email, I may require screenshots or files from you. My address is at the end of the FFX manual.

I just dropped a ton (literally) of water on a fire from the small Robinson and a tiny 160lb bucket on the highest density. I couldn't detect any massive stutters.

Best regards

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now