Bobsk8

Controller setting keeps reverting to on after deleting

Recommended Posts

This is a strange problem I discovered yesterday with P3D V 3.4.  I have been using FSUIPC for all my settings for quite awhile. I have some A2A aircraft, where the trim works much better if I use the A2A control config program, and it order to do that I haved to enable the controller settings in P3D, which otherwise I have disabled. So with the controller settings enabled in P3D, I still have everything running with FSUIPC because all assignments in P3D are deleted. 

Now here is my problem, I delete the parking brake setting for my joystick in P3D, hit OK,  and assign it in FSuipc. Everything works fine until  I close down P3D, and then restart P3D, and now the parking brake setting in P3D is enabled again. This happens every time. Does anyone know why it will not remember the Parking brake setting after I delete it? 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I'm having similar issues. I use FSUIPC for most things but I prefer the hat switch settings in P3D. I know Pete  suggests that you don't mix settings, but I never had an issue with this setup in FSX. With P3DV4, I keep seeing things enabled after they were deleted. Something seems a little funky.

Where are the controls settings stored for P3D?

 

Share this post


Link to post

I figured it out right after I posted this question . ( problem with getting old). Many months ago I got tired of P3D resetting some control assignments periodically. My cure was to make the XML file for controller settings located here(C:\Users\YOUR ID\AppData\Roaming\Lockheed Martin\Prepar3D v3\Controls..)    read only in windows. I totally forgot that I did this, so yesterday when I would reassign the parking brake assignment in P3D to off, it would not update the XML file. So just now, I unchecked the read only assignment, deleted the parking brake assignment in P3D, and saved it. Then I turned Read only back on again, and assigned brake in FSUIPC.  Now everything works properly. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now