Recommended Posts

I recently acquired a Saitek X52 (not the Pro version) throttle and stick and I think I have a problem with the Y axis (elevator)

I noticed through FSUIPC that the output values of the elevator axis stop changing about halfway through the stick's travel, i.e. you can move the stick past where it has any effect on the aircraft elevators.

Is this normal for an X52? I had an X36 previously and that changed values through the full range of movement.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you looked at that axis movement in the Windows USB game controllers dialog window? That should tell you if there's a hardware problem or not.

Share this post


Link to post
Share on other sites
15 hours ago, odourboy said:

Have you looked at that axis movement in the Windows USB game controllers dialog window? That should tell you if there's a hardware problem or not.

The Windows controller window shows the same thing; deflection markers reach the edges of the box about 2/3 of the stick travel in both X & Y axis.

It just seems very strange that pots or sensors don't cover the full stick travel

Share this post


Link to post
Share on other sites

I have the x55 and it shows full travel, so I'd assume the x52 should show the same behaviour. Hmmmm...

Share this post


Link to post
Share on other sites

Just whipped the base off to see if there's anything obviously wrong but all looks good. No play, nothing loose and no pots to clean so looks like I'll just have to put up with it.

I might try Saitek/Logitech support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now